Layout Viewport not updating?

I have been having issues of late where the Layout viewport is not updating the latest version of the model. When you click on the viewport you can update model reference. You can also relink model reference. When I look at the model reference last saved date it might be a couple days or weeks old. Even though the sketchup model has been updated a few min ago. Why is it not updating the model reference? In the past, I could just make changes in the sketchup model and save them, go over to the layout model and go to the viewport and update model reference. The changes would come through. Any suggestion on my problem?

It would be a huge help if you’d share the LayOut file. I expect the answer to your question would be simple enough to resolve.

There are two common reasons, though. First, the scene properties have been modified for the viewport in LayOut. This modification overrides the settings for the scene in the SketchUp model Hitting the Reset button in the SketchUp Model panel will return the viewport to using the scene properties.

The other common reason for this is that the SketchUp references for the viewport is not connected to the SketchUp model file you are working on. This can happen if you copy and paste from SketchUp to LayOut. May not be an issue in your case if you’ve already tried relinking to the original SketchUp model.

Again, seeing your LayOut file will make it easy to determine what is causing this for you.

Please complete your forum profile with SketchUp version, operating system, and graphics card. That information helps us help you.

Hi Dave, Thanks for help. Not sure what you mean when you are asking for layout file? You want me to upload the layout drawing file. This is a dropbox link to the file. Dropbox - Yates.layout - Simplify your life
I also attached the ref file and you can see that the sketchup file is not updating. Processing: Screen Shot 2021-12-03 at 10.15.12 AM.png…
Thanks for the help.

Yes: That’s it.

When I open your file I see a couple of problems. Notice that the Camera properties for the selected viewport show as modified (dark background in the Camera section and the Reset button. Any camera changes you’d make to the scene in Sketchup used by that viewport will not carry over to the viewport because your changes in LayOut override the settings in SketchUp. Also the label leaders for the other viewport all point off toward a part of the model that isn’t visible in that viewport now. This implies to me that you panned and orbited the camera in LayOut for that viewport. Then at some point after the labels were added you hit the Reset button. If the viewport is made larger it is possible to see where those leaders are anchored.

Here I’ve reset the Camera properties for the left hand viewport. Clearly you double clicked into the viewport and zoomed the camera.

Best practice is to avoid making changes in LayOut that result in modified Camera settings. There’s really no need to be clicking intot he viewport to position or zoom the camera. You should be setting up the scenes correctly in SketchUp. Remember if you override those settings in LO, you are telling LayOut to ignore the changes you make in Sketchup.

It would be a good idea to purge unused stuff from your LayOut files as well as your SketchUp files.

Before purging


After purging.

Also make sure you are using tags correctly. ALL edges and faces should be created and remain untagged. Here I’ve fixed the incorrect tag usage in the SketchUp model file used for the lower left viewport…
Screenshot - 12_3_2021 , 3_27_31 PM

And purge unused:
Screenshot - 12_3_2021 , 3_28_03 PM

Purging unused stuff will help to keep file size down and keep both your SketchUp models and your LayOut projects manageable.

Purged another SketchUp model file. This reduced the .skp file size by 72%. I expect to see similar results with the rest of the .skp files in the document.
Screenshot - 12_3_2021 , 3_36_41 PM