Large tool set is microscopic in Windows 8


#1

Today, I watched a newcomer to SketchUp struggle with it on a new laptop running Windows 8. The menu bar across the top of the screen was tiny. The large tool set was tinier–almost to the point of being useless. And somehow, the Move tool had disappeared from the large tool set and could only be accessed from the Tools drop-down menu.
I’m a Mac guy, so I haven’t paid attention to SketchUp on Windows. But has anyone else tried to use SU with Windows 8 and found similar odd things happening to the large tool set and such? If so, does anyone know how to remedy those problems (other than scrapping Windows and buying a Mac)?
Best,
dh


Using 15.6"@4k (3840x2160) with large dpi setting on Windows 8.1
#2

Hi David,

Late last March I migrated my desktop workstation from XP Pro to Win 8.1
SU 2014 displays as expected on the dual monitor setup I’ve used for years.
Display 1 1920 x 1200 (native) SU GUI maximized
Display 2 1024 x 768 (native) SU Model Info and Dialogs

Most likely the problem you witnessed stems from the recent introduction of high-resolution screens.
Fellow Sage @Aerilius describes the problem and offers some solutions over here…

.

Since SU 2013 toolbars for SketchUp on Windows OS are customizable.
That means the user can also “disassemble” the native toolbars.
They can be reset back to their default configuration using the reset buttons in the Toolbars Dialog.
To open the dialog click … View > Toolbars or Simply right-click on any existing toolbar.

-Geo


Bad formatting on 4k UHD displays
SketchUp GUI too small on Surface pro 3 even when global scaling to 180%
#3

As far as we found out, the issue of tiny user interface elements occurs on high-resolution screens. You need to know that modern operating systems, including Windows 8.1 (that your colleague probably has), offer to scale legacy applications if they don’t support high dpi settings on their own.

Unfortunately SketchUp blocks this compatibility option by accident, meaning on one hand SketchUp does not completely support high-res screens, and on the other hand SketchUp prevents Windows 8.1 to scale the application bigger.

I wouldn’t have too high hopes that there will be a fix or solution in SketchUp 2014, but to make the problem bearable I’d suggest:

  • In this topic I suggested to place a modified manifest file next to the SketchUp.exe in the hope it allows to enable the “Compatibility → Display scaling on high DPI settings”. I don’t know if this succeeds, it might just as well fail.
  • If the toolbars remains too tiny, you can use SketchUp extensions that offer alternate, scalable user interfaces. For example LaunchUp has a dynamic toolbar and scales well. There is unfortunately no extension that can help with the tiny value control box or the aperture (snapping distance) in drawing tools.
  • You can use a virtual machine (like VirtualBox) and install SketchUp inside. Virtual machines start quickly and can be comfortably scaled up/down to any size. This comes with a little performance cost, but is the best solution that is specific to SketchUp.
  • The last resort is to reduce the screen resolution, for example by setting it from 3200×1800 to 1600×900. This reduces the resolution of the desktop and everything and makes everything blurry.

Size of menu and icons
#4

Dear Geo and Aerilius,
Many thanks for your prompt and thorough replies. They’re most helpful.
Best,
dh


#5

It seems like this will become a bigger problem as more people are forced into Windows 8.

Is Google working on a fix? I hate having to wear glasses when I am using SU.

Thanks,
DT


#6

SketchUp is a Trimble product, Google has nothing to do with it.
A new home for SketchUp — SketchUpdate … the official blog
Posted by John Bacus, Product Manager, SketchUp — Thursday, April 26, 2012


Windows 8 has nothing to do with it.
It’s a display issue which occurs on certain hardware, I. e. high-resolution screens.


#7

Google isn’t working on a fix, and presumably won’t ever. However Trimble has been putting more resources into SketchUp so there could be a chance to tackle this problem somewhen (if Google hadn’t left over so many problems to solve). I lobbied for this bug already in early 2014, but sometimes issues need to be burning urgent to compete over other high priority items.

And by the way, you are not forced to Windows 8. But even if you exercised your freedom of choice, it doesn’t make a difference that SketchUp does not support high dpi screens.