Any way to change measurements toolbar larger

I’m new to SketchUp Make, as I’ve just installed it a couple of days ago. The problem I’m having is that the Measurements Toolbar is way too small to read. This stems from my configuration, and I can’t figure out a way to make it larger so that I can read the dimensions.

My laptop is no slouch:
Core i7-quad core
Display Adapter Nvidia Quadro K2100M GPU
15.6" monitor with a resolution of 3200x1800, hence my problem

I need to be able to scale up the toolbar at the bottom, by 100%, double the size. I have this issue with some other programs as well, but in Sketchup it seems like I’ll really need to see those numbers.

I uploaded a screenshot:

Scale it to full screen on a 15" monitor to see what I see.

I searched the preferences but could not find any setting that I could change to solve this. Anyone know of a setting I can change?

The issue comes from many applications (including SketchUp) being built to screens with a fixed pixel size as it was common for decades. With the introduction of high-resolution screens, operating systems allow to adjust the user interface scale. However still some elements of the user interface are drawn to a fixed size in pixels, while others respect the global scale.

There are generally two approaches to get an application readable that does not work correctly with different resolutions:

  • you can decrease the resolution of your entire screen (use 1600×900 instead
    of 3200×1800). This makes everything and the whole desktop blurry.

  • in Windows 8.1 you can keep the desktop sharp (3200×1800, scaling: 200%) and decrease the resolution only inside specific applications:
    right-click the executable or shortcut and enable in the properties “display scaling on high-dpi settings”.

It would be great if you could give feedback whether the second solution gives the expected result, if not please post a screenshot of the SketchUp application window and the SketchUp.exe/Properties/Compatibility dialog.

I left windows at 3200x1800 resolution, and turned on Display Scaling for this particular app. It looks the same. Here’s the screenshot:

I found that I could turn on View- Toolbars - Measurement, and it is indeed larger, but it is also truncated. It only shows the first measurement, and ellipses (…) . So that’s useless.

Ok, it seems the SketchUp application states to be “dpi-aware”, and then Windows’ compatibility option doesn’t work (rendering the app at low dpi and then upsampling).

I fear if there is no further maintenance release we have to wait until 2015.

Thanks for your info. I’ll just find another program to use since this is really unusable unless I use an external monitor. I’m not willing to switch to lower resolutions on my screen as I do a lot of photography and video work on my laptop as well. That’s where the resolution really helps.

Thanks again.

I had reported it some time ago (0253), but it hasn’t gotten attention yet.

There is a slight chance that this workaround works: You could try to place this manifest text file in the SketchUp 2014 folder (next to the SketchUp.exe). You can open it in a text editor to verify what it contains. It should override the incorrect “dpi-aware” property so you can enable per-application scaling for SketchUp and keep your desktop and photo editing applications at high resolution.

Unfortunately the manifest text file is for when you are recompiling the app. The manifest won’t help.

The one thing that could help is if the measurements toolbar would just be wider. I’m not sure why it has a fixed maximum width. This would be an easy easy fix. They allow me to change to vertical or horizontal, but I cannot resize it wider. Without resizing it wider, the text gets cut off, such as “1287mm, 339…” and doesn’t show me all the digits. It is readable however.

I am thinking of putting a magnifyier on a stand over the corner of my laptop screen just to see the dimensions.

I also find it interesting that for a CAD program, they don’t support high resolution screens. Having a high resolution screen is one of the most useful things for CAD work. I used to do quite a bit of autocad, and having a high res screen was the only way to go.

Any other suggestions? I want to get sketchup working.

I had thought the additional manifest file would override (even without compiling, we had done that to force SU8 to use themed controls).
But even changing the width of the box - as simple as it might be - requires the SketchUp team to do another release.

The OS X version of SketchUp received some care and does not have this problem - but I agree that a platform+license change is not an acceptable solution.

So otherwise one could run SketchUp in a virtual machine like VirtualBox (what I am doing). When using scaled mode (ctrl+L) one can upsize the virtualbox window with SketchUp inside.

any solutions to this? I’m having the same issues.

It used to. But Microsoft changed things for security purposes (I think.) It is now actually much harder to get an external manifest to load. It needs to have a different resource ID than the internal manifest.

You know when you’re doing work you can just change it back

Is there any official statement from Trimble on this issue? We have to replace some workstations sometime this year and would like to get 2560x1440 displays so my eyes won’t scream after looking at my beautiful Mac display. The resolution issue has been around for a while now, and I thought it would for sure be fixed in 2015, but it was not. Is it on the agenda for 2016? C’mon… high-res displays are becoming somewhat of a standard.

The official policy that they have repeated over and over, is that, because they are a publically traded company, they are not allowed to make “forward looking statements.”

When doing a sustainable investment into technology, I wouldn’t compromise some months backlog of one application against the benefits of enjoying high-dpi in other applications and for many following years. But that was my personal rationale, and for the time being I get along with workarounds for SketchUp.

Whether it will get into SketchUp 2016? Unfortunately we can not say more than a “possibly”. I agree that as customer service it would be very supportive from SketchUp if they could also give advice on this.

Anyways a fix wouldn rather be maintenance of the software than an innovative surprise feature that needs to be kept secret.

I was experiencing this problem in Make 2017. I solved it by clicking “Reset All” in the toolbars menu. " view > toolbars > reset all ". After that, the dimensions bar was no longer cutting off half of the info.

Please do not wake up old topics (4 years) because the content could be outdated:

In this case, already SketchUp 2016 and finally SketchUp 2017 have already added high-DPI support on Windows, so SketchUp 2017 Make should not have the same problem that was originally reported here. This topic is about a different cause (requiring a different solution) even if the symptoms may look similar.

Your solution for further toolbar oddities may still be useful because toolbar sizes/positions still can sometimes get messed up (especially when changing displays or migrating settings).

I added my solution here because while searching for a fix this is the only thing with Identical symptoms that I could find. Btw, high-DPI support was never confirmed to be the cause. I don’t do forums and probably never will again, however I thought that if this was the only thing I could find related to my problem chances are that would be the case for others as well. Sorry, Boss, won’t happen again.

1 Like

Sorry, if you missunderstood my intention to give a helpful hint with reasoning, but such a wording is not very appropriate. As I said, it is good to have your solution here because people search with different words, and if the search guided you here, it will also others. :+1:

the latest updates are 2023 versions and the problem is still relevant. no one has solved it. my laptop has a 4k screen and 250% recommended windows scaling. the values in the toolbar are truncated. in addition, when creating a new material, I cannot immediately adjust the color. in the material creation window, palettes are not displayed correctly, even stretching the window does not help. therefore, I’m staying on version 23.0.419. in this version, the same problem with the measurements toolbar. in addition, the selection is reset during autosave, which was not the case before.