Measurements Tool Bar Only Displays One Axis of Measurement (Clips the measurement window)

Pretty much the whole story in the title. I’ve searched and haven’t found anything on this specifically. It doesn’t seem to be a window sizing thing since the measurements tool bar display is exactly the same as the bottom tray display and both are cut in half, even when I drag the measurements box out of the tool bar to mid screen in its own box. Screen shot below.

I do not see this problem on Win 10, on an external UHD display at 150% scaling.

We’d need to know details of your display that you are using SketchUp on.
FYI, SU2023 can only use displays at recommend resolution and recommended display scaling.
Custom resolution or scaling are not supported.

Dell Inspiron 7573 Laptop
Windows 11 Home
Intel i7-8550U CPU
NVIDIA GeForce MX130/PCIe/SSE2
Display set at 250% (Recommended). I have tried the others
Resolution 3840 x 2160 (Recommended) I have tried the others

I ran the Repair thing from the installer with no change to the problem

Have you tried a scaling of 150% or less (sorry, I don’t know what “the others” includes).

OK, so this is kinda weird.

If I open SketchUp at the recommended scaling (250%), then scale down with it still open (all the way to 100%), the window size scales but with no change to the problem.

If I rescale down to 150% with SketchUp closed, then open SketchUp, it’s about 90% better but still clips the end of longer measurements.

Rescale to 100%, then open SketchUp, seems to be a normal sized measurement display window and doesn’t clip anything, but at this scale the numbers are barely legible.

If I open SketchUp at 100%, then scale up to 250% without closing it, the window scales back up as expected but is super pixelated and grainy, though the measurement display window still remains “normal” and doesn’t clip the end.

Here’s a screen shot at 100%:

Have you tried changing the resolution down instead?
My 28" monitor is at 1920 x 1080 with 100% Scale and that works perfect for me.

1 Like

Make sure that SketchUp is using your Nvidia GPU and not the integrated Intel UHD Graphics 620.

Also see if there is an updated graphics driver from Nvidia.

So it appears that if I decrease the display resolution and play with the scaling I can get it to work, but then everything becomes grainy and not as crisp as the 3840 x 2160. I mean, it should work at the best resolution for my screen, right? Older versions going back to 2017 and Free always worked just fine without messing with screen settings.

The graphics card info I pulled from the SketchUp menu, so I’m assuming that is what it is using?

I’ll look into NVIDIA updates, but I just did an OS update and restart with no change.

SketchUp just migrated to using the Qt framework for the GUI. This is an ongoing migration and there are “hiccups”.

This is not current hardware, did SketccUp display with Win 10 Installed? It is possible this is the result of old hardware and Windows 11.

Not sure. AFAIK this laptop has always had 11 installed, but not sure about that. I don’t really pay attention to the updates, they just install themselves. But the issue has been present as long as I’ve been a pro subscriber (2 months or so) and I think it’s been 11 that whole time.

Maybe I just need to “accidentally” drop this one and get the company to get me a new one…lol

A quick search suggests the Intel 620 graphics was released in late 2016.

OK, so it’s not the latest and greatest graphics system, but I’m also not using it for gaming, just drawing lines on the screen. I would expect that might be a problem for 3D rendering etc, but this is just numbers displaying in a box. Seems like basics like that should run on Windows ’95….lol

Your CPU is from 2017 and is now discontinued.


When I bought my notebook, I purposefully chose an FHD resolution as I knew UHD resolution would be too much for a 15-inch display (ie stuff too small to see.) I planned to (and since have) gotten a external 28" UHD display.

Be aware that there also is another Windows setting to make text larger that might be again increasing your VCB (Measurements toolbar) text. On Win 10 it is under Settings > Ease of Use > Display > Make text bigger
MS may have changed the names of panels on Win 11 slightly.
EDIT: I guess it is Settings > Accessibility > Text Size

That is set to minimum setting (100%)

1 Like

Windows Update doesn’t automatically install new, correct Nvidia drivers. You have to go to the Nvidia website and downlod and install the newest driver for your graphics card type.

Looking at the Nvidia website, the newest driver was released a week ago.

Latest driver installed, no change.

Just downloaded SketchUp 2022, dimension text box displays properly in that version.

So, clearly something has changed with 2023 as 2022 works fine with default monitor settings and “older” laptop.

I’ll just use 2022 for now unless someone here has some other ideas I might try, aside from buying a new computer…

Thanks!

1 Like