"Invisible Mode"? "Cloaked"? LOL... Saved projects open, but, the work area is BLANK

After using SketchUp Pro on this PC, I have several projects saved to it, but, now when I try to open them, I get nothing on the screen… not just a problem with one of the files, but, ALL of them happen the same way: SketchUp Pro appears to open just fine, but, will not load my projects in the work area. Each component in the project IS VISIBLE in that drop-down area, but, even when I try duplicating them, or create a “new” line or shape, they’re invisible. Not even the axes are showing. Windows10 on SurfacePro PC. I AM able to open the files I created on my other, older PC.
Do you think it’s a SETTINGS thing in SketchUp I’ve somehow screwed up? I’ve looked at all I can think of, unless there’s some cloaking extension I don’t know about (kidding, of course)… Or is it more likely a Windows problem? Very frustrating.

TIA, Deb

Can you confirm your system details…

However, it sounds like a Graphics Card issue…

Have you updated your GC Drivers and restarted SketchUp?

In SketchUp Preferences > OpenGL what are the settings?
e.g. try switching off Fast Feedback…

Also check your NVIDIA Control Panel, and ensure that it’s set up to allow a 3d app [like SketchUp] to choose its own settings…

1 Like

Thank you.
It’s Intel HD Graphics 520
GL version 4.5.0 - Build 24.20.100.6136

I can’t find how to check the NVIDIA Control Panel.

Your Profile says you have [had?] a NVIDIA GC.
If you have one there’s a Control Panel, but you now say Intel HD Graphics 520 !
Then there’s Win 10 v. Win 7 etc…
Some confusion here too !

Some Intel Graphics Cards are well know to cause issues with SketchUp.
Win 10 updates sometimes break their drivers too.

Try getting the latest drivers installed from their own web-site…

Also check the forums - there are many posts on related GC issues…

Sorry for the confusion, my profile must have the info from the old PC.
The one with the problems is the SurfacePro Windows10 with the Intel card.

Thanks again. Windows doesn’t think the driver needs updating, but, I will go directly to its site and try there too.

Well, according to Intel’s site, all of my drivers are up to date. 'Will start searching the forum again to see if there’s a related fix already found. Thanks.

@debk Reminder to try this …

Do a full forum search…
But look at these [there are many…]:
White screen and and no possibility to design
GPU Intel HD 520 vs AMD Radeon R7 M360 2GB
Model Disappeared, but "Scenes" Show Content


Also note the requirement about installing SketchUp by selecting its installer's exe file's icon, right-click and choosing "Run as administrator" - because it's already installed, choose "Repair" when it's offered...

Thank you, TIG and Dan.
Problem solved. It was the “Fast Switching” option; off now. That’s a relief.
I guess that means my graphics card is ‘inadequate’?

Pretty much. Integrated graphics cards are not recommended for SketchUp.

By the way, maybe you could update your profile with the correct information.