Everything is invisible when models are openend after latest windows update!


#1

My Surface Pro (5) i7-7660U just went through a windows update this afternoon.

Since then, when I open SKP models in pro, there is nothing “there” in the view window! New models are the same.

It acts like things are there, but I can’t see anything…

Maddening–I need this to work or I can’t do any work!


#2

What version of SketchUp are you using? What graphics card is in your Surface Pro? Please fill in your profile correctly. Complete information from you helps us help you.

Try updating the graphics drivers directly from the GPU supplier. If there’s an Nvidia card, make sure SketchUp is actually using it and not the integrated Intel Graphics adapter. Windows updates are notorious for screwing up graphics drivers.

Also in SketchUp’s Window menu, open Preferences>OpenGL and disable Use Fast Feedback. Sometimes that helps.


#3

THANKS! I disabled Fast Feedback as a first try at it and it works now!

For what it’s worth, I’m in Sketchup pro 18.0.16975 & my graphics card is just the onboard one for the surface pro 5…


#4

Just be aware that the fact that turning off fast feedback makes it work tells us that your graphic card or driver isn’t up to the task of running sketchup fully.
Try updating the driver and see if you can turn fast feedback back on.
Generally speaking, integrated graphic cards are not ideal for sketchup, I have an intel iris on one of my machines and I know its limitations. The difference on a machine with a dedicated Nvidia card is significant. My >10 year old I3 with nvidia runs rings around my I7 with intel Iris when it comes to larger complex models.


#5

Yes, since it’s a Surface Pro, I’m limited to the onboard intel GPU, which is indeed an Iris Plus Graphics 640. I did the Intel driver scan and I have the latest “greatest” installed (from May, so maybe a new one will come out soon and fix this).

Fortunately I do not need particularly huge models (my architectural models only really get fat when I’m adding 3d entourage: cars, trees, etc.) I didn’t have this SKP trouble with my surface pro 2’s GPU – is Fast Feedback a newer feature for SKP? If I turn off anti aliasing entirely, then I can use fast feedback. Otherwise I have to turn FF off, but I can do maximum texture size without a problem, and even crank anti-aliasing up to 16x; admittedly it starts to lag at that point, but no weird disappearing act.

Thanks again for the help!


#6

The Fast Feedback option has been around for a long time. It’s a setting that can help to compensate for inadequate graphics processors.