Model not displaying, all other sketchup options seem to work


#1

Sketchup no longer displays the model in the window. All the tools and properties windows act like they are working correctly, even the outliner. The software had been working fine for quite a while. Even the dynamic components properties and options windows work, but no model to see.
Any ideas?


#2

What happens if you hit Zoom Extents? Maybe it’s just out of view of the camera. Did you try selecting a group or component in Outliner and then use Zoom Selection?

Uploading the SKP file would help us help you without wasting time guessing at what the exact problem is.


#3

I tried zoom extents, I can even randomly pick with the selection tool in the model window (where nothing is displayed), and get properties and options for the invisible thing I picked. I don’t think it is a problem with the file, as I have opened many different saved files with the same result. I think it might be a software problem.
Also, in a new file, I draw a rectangle. Everything acts as if I did, but nothing is displayed.


#4

Probably a graphics problem. See the recent warning about using the Surface for SketchUp.


#5

Thanks, I checked that out earlier. It was working fine on my system up until today. I even tried uninstalling some windows updates, to no good result.


#6

What is the graphics card being used by SketchUp?

SketchUp hasn’t changed since you installed it so if it was working before but isn’t now, you need to be looking at what has changed since it worked.


#7

How do I check that? (which graphics card?)


#8

In SketchUp, go to Window>Preferences>OpenGL. Click on Graphics Card Details.


#9

I went to that window, and there is only one card. I unchecked a box called “use fast feedback”, and now it works again!!!

Thanks for your insight.

Matt


#10

Ah… That was going to be the next suggestion after checking to see what graphics card.

So what card is it? The fact that everything apparently once worked with Fast Feedback enabled and now doesn’t points to a change in the graphics drivers as I suggested before. Microsoft is good at pushing graphics drivers that don’t adequately support OpenGL. For that reason, you need to keep an eye on automatic updates and be suspicious of them.


#11

Intel Iris Plus Graphics 640. I have been bit by auto update before. I think it does more good than harm, but the Jury is still out on that.


#12

Intel Graphics cards are notorious for rather poor OpenGL support anyway and Microsoft doesn’t seem to help with their updates. If you do a search on this forum for Intel Graphics you’ll find plenty of cases where updates to Intel graphics drivers have “broken” SketchUp. And I’ve seen other similar reports for other software that depends on graphics that support OpenGL.


#13

I think I had a problem with Libre office that could be contributed to that. I will mark this as solved, and thanks again for your help.