Select tool not working in SketchUp Pro 2021

I was in the middle of working in a file when all of a sudden my select tool stopped working. When I click on the button, it “lights up”, and gives me the arrow to use, but when I attempt to select something in the drawing space, it doesn’t do anything. Nothing has been locked or hidden and I am still able to select objects by clicking on them in the outliner, but I currently need to be able to get to the faces of the object. I have tried both restarting the program as well as my laptop and the problem still persists. Any suggestions would be much appreciated!!

It would help if you’d share the .skp file so we can see what you’ve got going on.

What happens if you get the Select tool and drag a right to left selection window over part of the model?

Would love to be able to upload it but it looks like the file size is too large…
Dragging pulls up the selection box, but again doesn’t actually pick anything up.

Upload it to Drop Box or Google Drive and share the link.

Also currently trying to reinstall to see if that does it

The .skb file is the backup file. It would be better to share the .skp file.

If you are reinstalling SketchUp make sure you right click on the downloaded installer and choose Run as administrator. Do not simply double click on it to get it to run.

sorry about that, here ya go
I can report that reinstalling also did not solve.

First thing: Set the camera to Perspective, not Parallel Projection. Do your modeling in Perspective view and save Parallel Projection for output.

Second, you might need to give your graphics card a chance to catch up. I’m not having any problems with selections but it is slow.

Setting the face style to Monochrome helps.

Make sure you are using tags correctly. In the file you shared, you have a lot of geometry that is tagged but shouldn’t be. ALL edges and faces should be untagged.
Screenshot - 7_28_2021 , 4_51_37 PM

And purge unused stuff from your file once in awhile. This file was quite bloated. Purging unused reduced the file size by 30%.
Screenshot - 7_28_2021 , 4_53_02 PM

Did you install by right clicking on the downloaded installer and choosing Run as administrator?

Note that the graphics card you list in your profile is not all that robust for 3D modeling. Integrated GPUs like that have never been recommended for SketchUp. You’ll want to do things like working with textures turned off to help improve performance.

Each of those cushion components is over 64,000 entities. That number of entities and the number of copies means there’s a lot for your graphics card to deal with. Considering the way the cushions are used in the model they could stand to be lightened quite a lot.

Well, with over 20 million edges, that model is going to be slow on any computer.

1 Like

Thank you for all the advice, I come from an industrial design background (still a student with limited hardware access) and this my first time using the program. I did all of my modeling in a different software I am more familiar with and just brought it in here for rendering purposes. For some reason I cannot fathom swapping to the different camera views seems to have fixed the issue though.

That’s only part of it. SketchUp is really designed to be used with the camera set to Perspective.

The excessive amount of geometry in your model is more the problem. Looking more closely I see there are screws and nuts used on the dividers and that they have screw threads. The screws and nuts have over 11,000 entities each! Is there any value in having that kind of detail that will never be seen in your render?

Those were included in modeling process as we will be required to show smaller details, exploded views, and show how everything goes together. I could however easily take them out of the model for the larger overall shots for the sake of speeding the file up.

I’m late to the party, but as I was reading your original post my first thought was, he’s working in Parallel Projection.
The problem with Parallel Projection and Zoom is that it moves the camera very differently to Perspective mode and what you see in front of you is not really true. You’ll usually notice that when you switch to Perspective the geometry jumps a long way away, or even jammed up in your face.
So what is happening is that the cursor is not really clicking where you think it is, or that’s how I look at it anyway, very unscientific.