Compatibility with MS Surface Pro


#1

I downloaded SketchUp Pro to my Surface Pro and used the licence of the version I have on my Desktop. It loads fine - but the 3D space is totally blank. No axis, or horizon, etc. Blank. The pen icon and other icons float around fine. But nothing shows up in the general field. I ran SK CheckUp and it says all is fine. Anyone with ideas why it’s not running well on this?


#2

In SketchUp, go to Window>Preferences>OpenGL. Untick the box for Use Fast Feedback. Any change?

Most likely your Surface Pro, like others, has an integrated Intel graphics adapter. These are well known to be lacking in adequate OpenGL support and are not recommended for SketchUp.

Please check your computer and add the graphics adapter to your profile.


#3

Voila!! Yes, that worked! Thanks so much, Dave!

DG


#4

I thought it might. As I added in my previous post, this is a common issue with integrated graphics.


#5

How do add the graphics adapter to my profile? Is this possible to do to the Surface Pro?


#6

You need to edit your profile. Click on the H in the orange circle up at the right corner of the forum page, click on the gear icon and then edit your profile.
Screenshot%20-%2011_21_2018%20%2C%2010_13_27%20AM

I was only referring to your forum profile. This won’t affect your Surface Pro.


#7

Got it . Thanks again.
DG


#8

Perhaps you could add the model number. That sort of information is useful when trying to help you with questions.


#9

Upgrading your graphics driver (download the latest directly from the Intel site) might help. Other integrated graphics users have reported that turning off Fast Feedback (in SketchUp: Window menu>Preferences>OpenGL) has helped too.