Display Issues with Surface Pro

Continuing the discussion from How to get this bezel form:

(1) Update the graphics driver to the latest.

(2) Try switching off Preferences > OpenGL > Hardware acceleration & restart SketchUp

there are a lot of people using a MS Surface Pro and claiming that it works fine w/ SU:

maybe the will jump in this thread and help you to solve your 3D display output glitches.