SketchUp Pro not working on a Surface Pro

sketchup

#1

SketchUp Pro installed on a Surface Pro.

Start SketchUp Pro and XY axis are not visible, not possible to draw, not possible to open an existing model.

That is how it looks like:


Main Window not available
#2

Try to update the graphics driver.


#3

In Sketchup Preferences>OpenGL
Toggle the “Use Fast feedback”


Getting my SketchUp to actually DRAW
#4

Graphic driver is updated.

by toggle, do you mean I should Use Fast feedback or should not use?

Thank you both for trying to help.


#5

I have a Surface Pro 4 at home and the last driver update caused same thing that you described. So I have removed the mark before Fast feedback, (Fast feedback should NOT use) and it helped for me.
So “toggle” it and see what is te best for you… :wink:


#6

after changing settings in the OpenGL dialog, do a SU restart for taking the settings into effect.


#7

This also worked for me with a Surface Pro 5


#8

i’ve just solve the same problem unmarking the opcion “usar respuesta rapida” then first one in preferences/openGL


#9

This is the solution when the drivers for the integrated Intel graphics adapter are broken which often occurs after a Windows update.


#10

hi thanks. is it possible repair the broken drives??
Thanks


#11

You can go to the Intel site to download their latest driver version and install that. It may help but integrated GPUs, especially Intel graphics adapters are notorious for less than adequate support for OpenGL and integrated graphics are not recommended.


#12

My solution was: :

  1. Surface Pro >> :wastebasket:.
  2. :shopping_cart:: Real :computer: with nVidia graphic card

The Surface Pro is a fancy, but not a good computer for “serious” tasks.


#13

:joy::joy::joy::joy:
thank
My surface was a present!!!
I know that it’s not the best solution but now its my unique solution


#14

Then “pray” :pray:t4: if Microsoft (and Intel) finally can provide a proper dirivers. Otherwise use the " Fast feedback" hack. :grinning: