Not sure what to do

I’ve been using SketchUp Pro 2015 with Shaderlight for a few years; the program worked fine. I had to download SketchUp Pro 2019 yesterday to my new computer. The program is completely unresponsive to key commands, none of the tools work. I’ve uninstalled the program from my computer three times and have reinstalled the same number of times with the same problems. No error message. I’ve uploaded a few screenshots that show what happens when I just move the cursor around. I may not be as knowledgeable about hardware as some but I’ve used SketchUp long enough to know what it is supposed to do. I just paid for full access to a program that I can’t use and am having to resort to using the online version just to get some work done. Can somebody please tell me what is going on and why this download is corrupt and what I can do about it.

Your screen shots indicate that the graphics card isn’t supporting OpenGL properly. Not uncommon with the GPU indicated in your profile. Try Window>Preferences>OpenGL. Untick Use Fast Feedback.

Also try updating the drivers directly from Intel.

Keep in mind that integrated graphics cards are not recommended for SketchUp.

In SU2015, there was an option to dump rendering duties to the CPU but that option went away a couple of years ago.

1 Like

Okay I will try that. Thanks.

1 Like

Also make sure you installed SketchUp correctly. That is, right click on the installer and select Run as administrator.

1 Like

There is a chance that Dave is wrong about the unticking use fast feedback. Older versions of SketchUp would believe the claims of the graphics cards, and would have that option checked. But, on Surface Pro in particular having that option checked would give you a blank document. Support received hundreds of emails and phone calls that were all the same symptom and same solution; unchecking that box.

With 2019.3 things were changed, and if you have an Intel integrated GPU, SketchUp now sets that box to be unchecked. That will cut down the number of support tickets from Surface Pro users.

Unfortunately, there are Intel GPUs that are more capable, and unchecking that box leads to a new symptom, where you get all of those crazy lines. Checking the use fast feedback box fixes that.

The general case is that if you see something that is graphically wrong, toggle the state of that box, from what it is now, to the opposite of what it is.

2 Likes

Thanks, yes. I installed Run as administrator. Can you please tell me what I can do next. Can I update my computer’s graphics driver to something that will enable the performance of SketchUp, and what do I need for Sketchup Pro 2019? Sorry…I am somewhat limited in my understanding. I understand GPU and OpenGL but the rest of what you are referring to is a little above my pay grade.

Maybe. Go to the Intel site and search for drivers for your graphics card. Download the latest one and install it. Microsoft has a tendency of pushing driver updates for integrated graphics like yours when they push Windows updates. Often those drivers break things like OpenGL support.

Updating the drivers with the ones directly from Intel may help but might not. The best thing to do is to get a computer with a suitable graphics card. Nvidia GTX series graphics cards have a history of excellent OpenGL.

FWIW, if you Google your graphics card you’ll find various benchmarking and other information. Here’s one:

Thank you. Buying a new computer is not an option. I appreciate your help.

Understood. I hope that you can find graphics drivers that will let you get by with what you’ve got.