SketchUp Pro 2019 bugsplat

Hi, SketchUp Pro 2019 is giving me a big headache. I can’t add any tool or change the window’s size, every time i’ve done it, it crashed and shut down with a bugsplat message. I’m new at this, need help, please, please, please…
Windows 10 Home 64 bits, Intel ® UHD Graphics 620

Very likely the problem is related to the integrated Intel graphics card. They are not recommended for use with SketchUp due to their inadequate support of OpenGL. You could try updating the graphics drivers direct from Intel. Don’t let Windows tell you whether or not the graphics drivers are up to date. Go directly to Intel’s site and get the latest ones.

Also, when you installed SketchUp, did you do it correctly? That is, did you right click on the downloaded installer and choose Run as administrator? Or did you do something else?

Don’t remember what I did really, so I’ll try both of your suggestions. Thanks

When you reinstall SketchUp, right click on the installer, select Run as administrator, and then when presented with the option, choose Repair.

1 Like

I tried both, I updated the graphic drivers and reinstalled sketchup, but there were no changes. Is my graphic card so bad or an older version of sketchup would run properly?

On versions 2016 or older, SU has the option to uncheck ‘Use fast feedback’ which might help.

There’s another option not to use hardware acceleration.

From 2017 onwards, you need a graphics card that will support OpenGL 3.0 or greater: 2016 only needed 2.1.

So an older version might work.