Initial "Make Component" takes excessively long time (SU Pro 2017)


#1

Why does it take such a long time the first time I use “Make Component” after opening an existing model?

It can take several minutes for that simple task to complete, but all subsequent operations are pretty much instantaneous. Even when I do something very simple, such as making a 2D rectangle, selecting the four edges and face, and “Make Component” sits there for dozens of seconds, or minutes, thinking about it, before eventually completing. If I then delete that component and follow the exact same steps again, it does it fast, practically instantly, with no problem. As long as I don’t close the model or exit SketchUp, it carries on creating components at normal speed. It’s only the very first time I do that after opening an existing model, and it’s rather annoying.

Does anybody know what might be wrong here? Or have a work-around maybe?

I’m pretty sure it’s not related to the hardware or operating system, as I recently moved from an ancient dual core Win 7 32-bit system to a state-of-the-art 8-core Win 10 64-bit system with 16 GB RAM, and it’s pretty much the same on both: it just takes forever the first time I use “Make Component” after opening a file. That’s part of the reason I upgraded the system, hoping this operation would be much faster…

(There have been a couple of similar questions from other users in the past, but they have all been closed with no apparent solution… )


#2

Try to make the initial components while keeping the components window/tab off. You’ll have to first save a skp file with the components window in the off mode and restart sketchup to make sure that when you restart, that components window is not displayed along with the other windows (material, soften, layers, entity info etc, that you might be keeping on )


#3

I suspect it has something to do with re-rendering the previews of all components but I’m not sure.


#4

Do you have the Outliner open? I remember reading about it causing lags.


#5

This sounds very similar to the problem I was having. I was also sure that it wasn’t a hardware. More importantly the problem was repeatable time and time again.

It turned out to be a graphics driver issue. Once I updated my nvidia drivers the problem disappeared.


#6

Thanks for all the suggestions, everyone! Very much appreciated.

However, the issue is till there.

The graphics driver is up to date, and the problem is definitely SketchUp itself, NOT the hardware. I just discovered that SketchUp incorrectly identifies the amount of memory on the graphics card: for some unknown reason, it seems to think that the Nvidia GeForce GTX 960M only has 1 MB of RAM! It actually has 12 GB of RAM (12237 MB, to be more precise). There’s 4 GB of video memory alone. However, the “SkecthUp Checkup” program thinks that there is only 1 MB. It reports: “Error: Your “GeForce GTX 960M/PCIe/SSE2” graphics card has 1 MB of graphics card memory. SketchUp requires a graphics card that has 256 MB or more of memory.” When I check the graphics memory reported by Windows, it correctly identifies “Total available graphics memory: 12237 MB”

I have no idea if this error with SketchUp’s inability to correctly identify graphics memory is related to the problem I’m having with the massively slow initial “Make Component” bug. I guess it might be, but I have no way of knowing.

The other issue I noticed is that the actual .skp model file grows by several megabytes each time this problem occurs. I have seen a file grow from 50 Mb to 56 Mb from just one simple operation of creating a basic cube. In other words: open the existing file, draw a rectangle, push/´pull it out to a cube, select the geometry, “Make Component”, wait nine minutes while it does that, save the file, exit SketchUp, and the file has now inexplicably grown by 6 MB. If I then open the file again and repeat the operation, it takes another 9 minutes to do that, and the file grows again, to maybe 60 Mb or so. It seems to grow by a random amount on each successive occasion, sometimes just a couple of kb, sometimes many MB. If I then purge the model, the file size does not decrease: it stays at the new, grossly inflated size forever after.

The only workaround I have found is to never close the file! Keep it open for weeks at a time, never shutting down the system, never exiting SketchUp. As long as I keep it open, it works normally after that first eternally long “Make Component”, and does not seem to have any further issues, unless I close the file and open it again. I can save the file, and even save multiple versions of the file, with no issues. The ONLY issue is the very first time I do a “make component” operation after opening a file.

So that’s where I am: the issue is definitely SketchUp, not a shadow of a doubt, and they don’t seem to be too interested in fixing it, or even admitting it. It’s not hardware, since it occurs on two entirely different computers with very different configurations. It is SketchUp itself.

Any other ideas from the experts here?


#7

This is apparently a know bug in the Microsoft routine that reports the graphics RAM to Checkup, and is not the problem in SU.

There are several threads on this subject - search this forum for ‘first make component’ or similar, and see if any of them offer solutions that might be relevant for you.

Does it happen in a new drawing with nothing already in it?

Does it happen when you start SU with the Outliner window closed and the Component Browser window closed? (Close them in an open drawing, then close SU and restart it.)

Problems with the graphics driver implementation may slow down creating or displaying component images in the Component Browser, and having Outline open in a large file or complex drawing seems to slow everything down.

These are palliative measures rather than solutions, though.

When you first installed SU, did you R-click on the EXE installer file and choose Run as Administrator?

If you didn’t, or don’t remember, try doing it again, and when the installer starts, choose Repair.

That has fixed the issue for some people.

There are also a few long threads about updates to Windows which have caused problems for users of different graphics programs as well as SU, where graphics driver performance has suffered badly, or hung the programs completely.


#8

I’m getting this same error after installing windows updates (today). this was in an existing model that was working fine.

Where can I find the SketchUp 2017 install exe for windows (64bit)?
I don’t have the copy of the installer saved which I would need to use to try the ‘run as administrator’ fix.

& I don’t want to go to 2018 yet.

Thanks
Sam


#9

Second time I have posted this today.
https://www.sketchup.com/download/all


#10

having the same issue… along with select tool lag with no fixes working… unnecessary delays…


#11

I’ve been keeping a blank, second sketchup window open and cut any component I want to create into the new window > paste in place > make component > cut > paste in place back into my main working sketchup window. (I use shortcuts for that process to make it speedy)

This issue seems related to SU 2017. When I switched to SU 2017 from 2016 I upgraded an existing model without any errors or component issues and on generating new components the lag comes in with 2017. When doing the same task in 2016 there is no issue.

For whatever reason there is no lag in an empty window but projects that have CAD or Revit models imported typically have the component lag as there are many components that translate from the .DWG files and I think Sketchup has a hard time dealing with all the thumbnails or “foreign” object information.


#12

Sorry I neglected to report back after the problem was fixed! Thank you so much, John. This did, indeed, fix the problem. After re-installing with “Run as Administrator”, as you suggested, the problem disappeared. It now creates components practically instantly right from the start, even on very large models, and the model no longer grows by huge jumps each time.

Thanks again! This is the solution.


@mvollrath, I’d suggest that you follow John’s suggestion. It might be the case that when you installed 2017 you didn’t do it with admin rights, but you had done that with 2016.


#13

Could you mark it as such, please, for other’s information?


#14

February 2018, and the problem has returned.

After the latest Windows update, it is broken again, and this “install as administrator” fix no longer works. I even deleted SketchUp completely and re-installed it as Admin, and the issue is still there, worse than ever. On a large model, it hangs for several MINUTES now… and then the file grows by several megabytes when you save it each time.

So yes, SketchUp is still broken, and this bug has still not been fixed (like numerous other bugs), even though it was first reported years ago. Yes, the developers try to blame it on Windows, or on the graphics driver, or on the phase of the moon maybe, but the reality is simple: it is a SKETCHUP problem, since no other application I have ever come across has this problem. Only SketchUp.

If there is no fix soon, I guess I’ll have to get a refund and switch to something else, because it is unusable like this.


#15

Having the same problem; SketchUp 2018 hangs for several minutes when creating a component (while working on a large model).
My current routine is; save model -> hide all windows -> create component -> drink coffee or browse some web pages.
Curious what is the best solution / workaround. Any suggestions?


#16

Did you try the solution suggested above? Namely: install SketchUp using the “Run as Administrator” option? That might work, but the problem will probably return with future updates of Windows, due to the generally poor programming of SketchUp, and the total lack of interest by the developers in fixing bugs (some of which have been around for man, many years, and never even acknowledged by Trimble, let alone fixed). So don’t count on this solution working in the future, even if it works at all for you.

One “workaround” that I have heard of, and that did work for several previous versions of SketchUp (all of which had this same bug), but does NOT work for SketchUp 2017, was to first do a “make group” on the geometry, then do the “make component” on that group. That worked prior to SketchUp 2017, but not any more. No idea if they tried to fix the bug and ended up making it worse, or if it was just coincidence that it stopped working.

The third “workaround” that looks to be promising is to forget about SkethcUp entirely (especially considering their stupid move of eliminating SketchUp Make" and replacing it with a highly degraded, disemboweled, and castrated web browser version). So if none of the above work for you, then dump SketchUp completely and move to Formz or something similar. I’m liking Formz, since it can actually read SketchUp files, to a certain extent, so your previous work is not totally lost.


#17

I did install SketchUp as admin.

I tried making components directly and making them from groups. There doesn’t seem to be a big difference.

Going to FormZ or similar is not a good business strategy to me (at the moment) - still enjoying my SketchUp workflow too much for that.

Trying to find a pattern in the delay…


#18

Just to be sure: you used the “Run as administrator” option to launch the installer app? (The result is different than being logged into an account with administrator privileges and then simply “running” the installer executable.)


#19

Yes I did


#20

OK, thanks for clarifying. My only other idea would be to disable all extensions, quit SketchUp Pro 2018, then restart with a problematic model and try creating a component. Maybe an extension is hooked into the create-component workflow and slowing things down. Did this slowness begin recently?