Initial "Make Component" takes excessively long time (SU Pro 2017)


#21

Yep I got this now and I didn’t have it on
SKP2017

Does anyone actually understand this problem - it’s always re-install, extensions when it’s a BUG


#22

@congellous, were any changes made to your software environment, between when creating components was behaving normally, and now when the slowness when creating the first component has appeared? Or has the first-component-is-slow behavior been present from when you first began using SketchUp Pro 2018 (I assume that’s where you are experiencing this issue; your profile doesn’t say)? Can you provide a list of the extensions that you have installed? Perhaps another user will recognize a potential issue with one of them.

The BUG, if there is one, might be in an extension rather than in SketchUp. That is why the subject of extensions has been mentioned. Extensions can do amazing things for and to SketchUp.


#23

This thread alludes to it being a known problem and the suggestions seem to be of the clutching at straws variety and usual re-install etc
Does anyone check the ruby extensions for problems ?


#24

It is a bug, and it is in SketchUp, not in any installable extension. No doubt about that. This happens even after a clean install, with no extensions present (other than those that SketchUp insists on installing, even though you do NOT want them, and which CANNOT be removed anyway…)

It appears to be related in some way to the way you install (or upgrade) SketchUp. If you don’t do it as “Administrator”, then you can get this issue… sometimes… at random.

Trimble has chosen to ignore it, pretend it does not exist sweep it under the carpet, as they do with a large number of proven bugs, some of them going back many years. I guess they no longer understand how the original code was written by Google, so they just seem to ignore these issues, and apparently hope they will go away on their own. It has to be one of the worst companies out there for nto listening to users, and not fixing blatant bugs. This is just one of many. The only known way to “fix” this one, is to un-install, the re-install as administrator.


#25

It’s crazy, years ago I tried to implement sketch up in a practice and they would of done it (200 seats) but the I.T department tested it for reliability and good by


#26

Same here. Am waiting since >10mins for SketchUp to become responsive again after a “Create Component” command.

Edit: it’s now 25 minutes and counting.

Edit 2: it took half an hour to create that component. Now I am trying to simply LIST the components in the components window. This is currently taking like another 20 minutes and counting. What is wrong with SketchUp’s component handling?


#27

I haven’t had this long “make component” thing which makes me wonder what is different between your system and mine.

Did you install SketchUp correctly by right clicking on the installer and choosing Run as administrator?

What extensions do you have running? Have you tried disabling them to see if there’s any change?

Where is your SKP file saving to?

How large is the SketchUp file?

How many entities in the component you waited so long for?


#28

Yep. And even stranger is that Trimble refuses to even acknowledge it as a bug! The keep on saying that all you need to do is to install with “run as administrator”, then everything is fine (which it is) but they never state that this actually is a bug, and never bother trying to fix it so that you DON’T need to install it as administrator. Strange way of doing business, and maintaining software. Along with all their other strange ways, and the very, very long list of other bugs that they never acknowledge, or address.

The only solution to this bug is to do as they say: un-install the software, then when you re-install it make sure you right-click and use the “Run as administrator” option on the installer itself. This does not actually fix the bug, of course, but it does seem to prevent it from locking up your system.

Good luck!


#29

Needing to install the software correctly by using Run as administrator does not mean there’s a bug. It means that due to the way Microsoft has set security for installing programs, Windows won’t install required files without using Run as administrator. This is not unique to SketchUp and if you prefer to blame someone instead of installing the software correctly, blame Microsoft.


#30

Sorry Dave, this IS unique to SketchUp. And if it is required to install SketchUp als administrator in order for it to run correctly, but Trimble does not tell the users to do so, they are to blame for this problem.

Btw., this seems to have fixed the issue (knock on wood)


#31

Sorry. It is not unique to SketchUp.


#32

Dave, the fact that two people claim that it is “not unique to SketchUp” doesn’t make it “not unique to SketchUp”.

Anyway, as I already said, if this is necessary but the users are not told to do so, Trimble is to blame. This is very basic and irrefutable logic.


#33

… and all of a sudden the issue is back again!

For no reason whatsoever.

One day it was working fine, and when I fire it up to carry on working the next day, the bug is back. I did NOTHING AT ALL to the system overnight, and neither did Windows Update, nor any other update. I did not even turn off the computer! It was running overnight. No updates, no new stuff installed, no configuration changes, no changes at all. But yesterday it was making components just fine, instantly, and today there’s a hang of thirty minutes (or more) from making the first component, each time I open a model, and then it adds about 10 MB to the file size when I save it. Each and every time, even though I did NOTHING to the model, other than create a cube, then delete it. So: “Open model”. “Make rectangle”. “Push-pull to make cube”. “Make component” … [go have coffee, take a nap, eat lunch, go to the gym, come back… nearly done!] … “Delete new cube”. “Stastics - Purge Unused”. “Save file as”… and the new file is 98MB instead of 85mb, even though not has not changed at all…

The ONLY thing I did yesterday to SketchUp was (stupidly!) allow it to install the “TrimbleConnect” extension update, which I had not allowed for a long time… and today it is trashed… again. Since there’s no way to delete or disable “TrimbleConnect”, it looks like I’m screwed. Again. Thanks Trimble! Will you NEVER learn to do customer support right?

So yeah, it’s a Trimble and SketchUp issue, no doubt at all. A bug that they refuse to acknowledge, and refuse to fix.

I’ll try the same-old “fix” as before: reinstall as Administrator (this losing all my configuration that has worked so nicely for so long…), and see if that works… Not holding by breath, though…


#34

… And it didn’t work. (See one post above, for the sad story). Uninstalled SketchUp, re-installed as administrator, and it is still taking half an hour just to create a simple rectangle (same procedure as above).
So it is hosed, for sure. No idea what happened, but it is SketchUp Pro is screwed to the point of being unusable now.
It probably really is time to move to FormZ, since there’s obviously never going to be a fix for this major bug…


#37

Interesting… I got notification by e-mail of two replies to this thread, yet when I come here to read them, there’s nothing! Deleted by Trimble themselves, I guess… I wonder what they are trying to hide? Perhaps the fact that there is STILL no solution to this ancient bug? Hmmmm…


#38

inappropriate content is the only reason I have ever seen a post removed…

if any three forum members flag a post, it will be reviewed and possibly removed…

it’s reviewed to ensure it’s not just a co-ordinated personal attack on the poster…

john


#39

According to the notification I got, there was nothing inappropriate about the comment: It was a question, asking if this long-standing bug has been fixed in SketchUp 2019. I don’t see how that can be inappropriate! unless it stepped on somebody’s toes at Trimble… Why else would such a comment be deleted? Is it now against the rules of the forum to ask if a bug has been fixed in the upcoming version?

The fact that it was removed in the short time between me getting the notification and actually visiting the forum, combined with your comment, suggest that there are some very trigger-happy “reviewers” and “moderators” of the forum, if a simple question about an upcoming version is deemed “inappropriate content” and summarily deleted…

Very strange…


#40

Was the comment related to this specific bug or just someone hijacking an existing thread to talk about any bug?


#41

These forums are not for discussion of beta testers or their experiences. The post in question was polling for feedback from testers, which is not allowed, so it was deleted.


#42

For what it’s worth, i’ve encountered this issue myself, and the following things were present at the time:

  • Large models involving imported geometry (eg IFC files) with a great many groups (1000+) or components nested in a strange way . Creating an extra component can ‘freeze’ the model for a long time.
  • Component libraries that are located in a network drive (SU takes a very very long time to load or view the components).