Components aren't cooperating

I got completely frustrated with uninstalling SUp 2016, reinstalling and having Components created within a few seconds or less for a day or two. Assumed it was a problem with my Window 10 so I reset it! This requires re-installing every program I use.

One of the first was SketchUp the first model I made was a cube, I selected it and made a component out of it, it took 8 seconds to create the component after clicking Create. Back to square 1.:cry:

Is the time to make the component constant for all components you make? Can you post a video showing how you are making the components?

PS - To capture the video, I recommend using Jing, http://www.techsmith.com/download/jing/, because it’s free and works well. Feel free to follow this tutorial on how to capture a video, http://www.techsmith.com/tutorial-jing-record-video.html.

No, with the attached video, after I made it, I exploded it then re-created it and it was fine.

But when I’m working on a model it seems that it’s never like groups, witch is instant.

Here it is.
2016-02-24_1119.zip (306.8 KB)

Also depending on the size of my model/component it can take considerably longer (minutes) to make a component.

It’s been a week since my last post. Just a report. I’ve spent most of the week messing with my computer. I finally got the Restore Disks to work and restored my computer to factory settings, tested SketchUp components in Windows 8.1 Pro (factory default) and it worked as advertised (<1 sec). Upgrade to Windows 10 Pro and the component creation was back to 8 seconds.

Also the problems I had with the Extensions Store Another first for me!, has not gone away.

Try testing your graphic driver. In SU, go to Window > Preferences > OpenGL and disable hardware acceleration. Restart SU.

1 Like

That solved both problems with SketchUp! Does that mean there’s something wrong with my graphics card or do I need to reinstall the graphic drivers?

Thank you so much!

It means that your graphics card and/or its drivers are deficient in some OpenGL function(s) that SketchUp needs. You can try updating (or backing off) the drivers to find a version that works, and also fiddling with the settings in the driver’s control panel (assuming it provides one). Search this forum and sketchUcation for mention of the specific graphics card and see if others have found settings that work for them.

AMD has a spotty record of OpenGL support as required by SU. Your driver worked in Win 8 I believe? Report the problem to AMD support. While your at it, offer to be one of their driver beta tester - they (and we, the SU community) need more SU representation.

Oops! The SketchUcation Extension Store dialog still pops up!

@slbaumgartner Upgraded to the latest driver, still required to disable hardware acceleration.

@catamountain Yes I tested it before upgrading to Windows 10, it’s hard to find the right people to email about this problem but I persist.

Rboppy,

One thing: Your graphics card type has a “M” in it. Does it mean that your computer is a laptop? If it is, have you checked in the 3D application settings of the AMD control panel that SketchUp and your other 3D applications are set to use the AMD graphics instead of some crappy motherboard graphics chip? My bitter experience here (albeit with Nvidia) says that the default Automatic selection doesn’t work.

Anssi

Yes it is a laptop, and no I can’t locate any settings on the “AMD Radeon Settings” that mentions software other than AMDs. And up unit 6 -8 weeks ago everything was working fine.

But you did upgrade stuff - like the OS, so the card’s 3D settings could have gone back to default.

Isn’t the AMD control panel still called Catalyst? The graphic settings are there.

As far I as know, the card has always been set to default, I don’t know how to address the issue that @Anssi recommended. I always assumed that SketchUp took care of those things.

Usually the graphics control panel can be found by right-clicking on your Windows desktop. As @catamountain said, it is called Catalyst… and the settings should be found in Advanced view, perhaps under Gaming(!).

Anssi

Thanks Anssi, I have found some Radeon settings: These are the gaming setting, I haven’t a clue which setting to change. And this is the Radeon installed software:

Just info I think.

P.S.
The Catalyst Control center was removed when I upgraded the drivers.

So it’s now called AMD Radeon Settings?

That first image above show Global settings. You want something called program settings. Try clicking on the arrow to the left of Global settings, or click on more… .

The left arrow is their back button, this is their more…,

I clicked on add and browsed to sketchup, clicking on sketchup just runs the software the first time, the second time you get this:


From here I’m completely lost.

In general, anti-aliasing mode should be set to application controlled, which it is. And Anisotropic filtering can be set to application controlled too.

It looks like the AMD card is enabled for SU. What’s under Profile Properties?