SU hangs if I make a component

crash

#1

I’m on Windows, SU2016. If I right-click, Make Component, SU freezes up and just hangs. Doesn’t matter the file or what kind of component i try to make. I have to force-quit SU.
This is what Windows gives me:
Description:
A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: SketchUp.exe
Application Version: 16.1.1449.0
Application Timestamp: 56ce064a
Hang Signature: 392b
Hang Type: 0
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Hang Signature 1: 392be0a042b1c62478f6fbbdb72c99ce
Additional Hang Signature 2: dead
Additional Hang Signature 3: deaddf6c5a3b526027e02e8582c7f4a2
Additional Hang Signature 4: 392b
Additional Hang Signature 5: 392be0a042b1c62478f6fbbdb72c99ce
Additional Hang Signature 6: dead
Additional Hang Signature 7: deaddf6c5a3b526027e02e8582c7f4a2


#2

This is a really annoying bug. Make the desired component a group first then context click make component. An extra few steps, but works consistently. The only things you need to do afterwards is set the axis location and name it.


#3

I’ve never had any problem making a component directly nor found a need to make a group first.


#4

Its crashing for most of us, or hangs for a considerable amount of time. It even happened to me today (which is ultimately why I’m here). I forgot this happened from time to time cause I haven’t been using SU for modelling. And to my surprise there’s many threads even on this forum about the problem that mysteriously doesn’t exist. Happens less on my rig, but all the time on my less powerful laptop.


#5

I never said that the issue doesn’t exist. Just that I haven’t had any issues like you and the OP describe. And I never use groups, only components.


#6

I’ve seen this. The best I’ve come up with is this happens after deleting a component that has many nested components and dictionary attributes.

Then create a simple cube and create a component. It can sometimes take minutes. After creating the first component, creating another is virtually instant.


#7

this sounds like you may have an extension that reads and writes attributes for ‘selected’ entities, triggered by ‘Make Component’…

a simple cube is made up of 18 entities that would need to be individually checked and tagged…

when a group is ‘selected’, it is a single entity even if it has a 20 cubes inside…

there are extensions that are known to do this ‘tagging’ even when not in use during the drawing session…

if more than one extension is doing this, SU can grind to a crawl and file size can also go very high…

john


#8

What are some extensions that cause this problem, pray tell?


#9

SU 2017
I disable all extensions except for my own and restart SU. I create a cabinet where each part has 1 attribute which is essentially a comma delimited record (only text). This extension does not have any observers. Trays are closed.

Then I create a simple cube, select all of its parts and turn it into a component. It takes 15 seconds or so for the ‘Make Component’ operation to complete. I then create a second simple cube and turning it into a component is instant.

I do the exact same thing in SU 2016 and all ‘Make Component’ operation is instantaneous.


#10

I always get picked on when I mention vRay, so I better not…

but any that require a ‘history’ will store attributes either on the model or components definition or component instances or on each individual entity, depending on the extensions functionality…

Dynamic Components, Advanced Camera Tools, Renderers, Thru Paint, Scalp, and many more do it…

most issues are caused when too many are trying at once…

only ThruPaint has a Purge option, so any models from the warehouse can be littered with useless data…

there are a couple of attribute reporter plugins that can show you what’s being written and sometimes has a clue to what wrote it…

I tend to start SU with most Extensions off, and only turn them on when I need them…

john


#11

I updated my graphics driver and the issue went away.


#12

I have the same problem. It’s driving me crazy. I cannot make a component without SU freezing and I have to End Task. I tried making it a group first and it didn’t help at all. Anything else?


#13

I had this same problem too, then found a solution: For some obscure reason that nobody can explain, SketchUp needs to be installed as “Administrator” not as a user. So when you install it, right-click the installation program and select “Run as administrator”. No idea why that would make any difference at all, but it did…

Until now! After the latest Windows update, it is broken again, and this fix no longer works. I even deleted SketchUp completely and re-installed it as Admin, and the issue is still there, worse than ever. On a large model, it hangs for several MINUTES now… and then the file grows by several megabytes when you save it each time.

So yes, SketchUp is still broken, and this bug has not been fixed, even though it was first reported years ago. Yes, they try to blame it on Windows, or on the graphics driver, but the reality is simple: it is a SketchUp problem, since no other application I have ever come across has this problem. Only SketchUp.

If there is no fix soon, I guess I’ll have to get a refund and switch to something else, because it is unusable like this.


#14

It has been explained, though.


#15

I happen to agree with Designer2020 and I see what Trimble is doing as a work around that causes a lot of grief.

I write C++ programs that require elevated writes during program installation. The installer that I use has a solution for all this. I simply add the following in with my installer software.

PrivilegesRequired=admin
and I need to add runascurrentuser

This produces the exact same results as right click and “Run as Administrator” without the hassle.


#17

And even explained why.


#18

You have no idea what I think and your statement is incorrect. I never suggested that you “made this up”

Obviously we have to use “RunAsAdministrator” with the SketchUp installer (at least for Windows).

All I said was in my OWN installers I don’t run into this issue.


#19

Been encountering this problem since 2017 upgrade. Seems to happen in files that have any sort of info that was once in 2016. Which is unfortunately almost every file I work with. Even does it when I group first and make component.

I Installed as Admin. Disabled All Extensions. Still having this problem.

Will have to use continue using just groups for now… which is ridiculous.

This should have nothing to do with graphics cards and drivers. It simply some sort of memory leak in the component creation caused by an unknown factor. Will probably have to upgrade to 2018 soon as most of our consultants are using it. Hopefully this problem doesn’t continue.


#20

I’ve had this issue for quite a while. I have a test script that creates 100 cubes - all as unique components. If I run it while the components tab in the tools tray is open then it takes quite a while for Sketchup to respond. After that I can create a component manually and it is instant.

If I run the script when the components tab is closed the script runs instantly. But when I create a component manually it takes quite a while for sketchup to respond.

I’m not convinced it is a memory leak. However I am thinking it has something to do with a difference when creating a component manually and creating a component within a script.

Interestingly a couple of peers have different graphic cards than I do and different processors yet we all seem to have the same problem.


#21

I’ve been fighting this problem all day. The program seemed to freeze in place, requiring a force close. except when the Esc key was pressed. Turns out, my use of an external monitor (1920x1200), used to extend my high-res (3000x2000) Windows laptop, sent the DC Creation Window to another dimension off-screen.

Fixed by setting the screens to duplicate, re-opening and moving the Creation Window to the left, then resetting my screens back to extend. Back to work!