Creating a component locks SketchUp


#1

Hello, I just noticed this a hour ago. If I make anything a component, it recognizes the axes point. Leaving the RGB axes icon and that is it. SketchUp then is frozen and nothing responds, NOTHING… I have 2 quick clips capturing it. As I have to re-start the machine to close S-UP.

It happens every time with my default template so I open S-UP with the default Urban Meter templet and create a cube. I can group it and edit it.

If I create a component version or try to explode a group to become a component. It freezes S-Up completely. I even open a new instance of S-Up and opened a saved auto copy from months ago. I made a cube and it to froze S-Up. When I tried to make it a component. Groups are not effected??

Here are vid`s and I will add anything I can …but this is weird. Looky here…>>>>>

GROUP

COMPONENT


#2

The Create Component window should open when you choose Create Component. Until you at least hit Enter, that window will have focus and it’ll appear that SketchUp is frozen. Where is that window opening? Did you have a second monitor connected before?

Try Window>Preferences>Workspace>Reset Workspace.


#3

It’s Thursday after the first Tuesday of the month.
Win Update.
Have you tried rolling back or updating your graphic driver. Or checked that your good card is still running Sketchup.


#4

Cool two birds with one stone.

BOX: Yes I received Win10 update yesterday and will check graphics.

Dave: It does not give the dialog box That is what is screwy, I do have 2 monitors and I float Trays and they pop-up on the other monitors. But after you select it and hit make component and even if you use the S-Up assigned key short cut (G) the default axes is placed and eveything is locked


#5

What happens if you hit G to create a component and immediately hit Enter?


#6

opening a fresh instance…be back…


#7

Enjoy the Q!! just made cube > push-pull > up r-to-l select -all hit G and… immediately axes is placed in the default forward-left corner. No dialog no nothing… I press the G key and frozen solid. I have to go into Windows select re-start. It has to force the instance shut to continue. Then offers it as a auto-saved options on re-opening S-Up


#8

But did you hit ENTER after hitting G?

Thanks. Waiting for it now.


#9

I cant … that is it the program stays fully functional. As soon as ANY way of select Make Component is clicked. Key shorted cut, context click or changing a group instance to a component. You can do nothing else… I hit G and hit Enter I get the Windows error bong but the axes is in place.
I hit the selected cube with a right click make component and the axes is placed.

Anything I click on produces the Window Error sound, so the courser is actively under control. Just nothing responds. got to use do a few personals we be looking out . I can build a complete model using groups and all Tools… as soon as I select make component, is when it locks…??? be back and no hurries~worries. I was going to offer a bit to a different post on a tapered curve. I was retracing the steps on how to get it started. I went to make it a component and shazam…


#10

Hit Make component, then go, alt and space together, then m, then tap any arrow key once and finally without touching anything else, move the mouse around until the Make Component dialog appears on your screen.


#11

so that is it. Anything I select and attempt to make a component instance of. It is completely high-lighted I hit capital G and I am frozen. Immediately hitting the Enter key I hears Windows chime out. The cube is still high-lighted with the axes now place in default. I was shown no dialog box that is always produced.

The courser is moving freely on screen but no icon. Or Menu Tab response.


#12

just got back -will open S-Up and try…thanks!!


#13

Basically if that turns out to be the problem @DaveR had it from his first reply. It is the ding that gives it away.


#14

doing quick screen vid, I just hit re-set work space, make a cube, selected it and it froze when I selected Make Component. be right back


#15

As an example, this shows what happens when the component dialog is off screen, all the frantic mouse moves and clicks are going Ding. Then I grab the dialog. So it really looks like it is hiding off screen for you.
Offscreen


#16

As long as I don`t Make anything a component the program works as expected. ANY attempt to create a component I have tried. The item is still high-lighted with the axes in place. Courser moves freely, but programs icons, key pad short cut Menu Tabs EXIT

BOX I am seeing your vid… what are you selecting off screen to grab that Create Component dialog box…??? My point is the trigger is selecting the component option. I have S-Up froze on my one monitor. If there are are open Trays they are on the other monitor frozen also.

You made a cube, then made it a component, it appears un-responsive *** at this point what did you do off screen to get that dialog box?? I have NO response to anything on the screen??


#17

I dragged it into the gif window because it was visible to me, but your Make Component dialog is opening off screen, somewhere between your main screen and your second screen or even off to the left or right in the land of pixels. Which is why I recommended trying the standard ‘move dialog process’
As I said, start the action by invoking Make component, this will put the focus on the missing dialog, then press alt and space together, this will make the context menu on the dialog open, then press m, this will select the move option of the context menu, a single tap of any arrow key will attach the dialog to the cursor and allow it to move with it, then moving the mouse around without clicking anything will bring the dialog into view, if you move it in the correct direction. Once in view a simple left click will place it on your current screen.


#18

This looks like it will take more time then un-installing S-Up and let it adjust to Windows. Box the update for Win10 was a Feature Update. Not just the standard Cumulative Monthly Security patch. ( I just shut off machine)…

I just shut off machine and re-started, now I get a dialog box as soon Make Component is selected…???
I have not used S-Up till today, Windows re-started twice after the Update. I had to re-start the machine 5 time to get the frozen SketchUp instance`s to close.

If it takes 36 hours for the update to filter completely in?? I don`t know but I have been burned hard by a bad Update from them and it Real Stunk!

This was the first FULL Shut Down Start since the update. Windows did the re-start after the install. I have re-started the program more then 5 times since then.

IF A COMPLETE SHUT DOWN was needed to solve this I don`t know. Usually when a program updates and self restarts I always assumed that it was done??. I am only guesting >>> but happy as it is making a component without locking up. With one monitor or both, what ever it was I am glad it is gone. WEIRD… thanks!!!


#19

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.