Su stops working when I make a component

su stops working when i make a component. Just started today…

bummer! what steps did you do?

following a tutorial? or playing around?
many things can go wrong…

hardware/3D warehouse components/etc.
try to upload the file.

Your profile indicates version 2018. Why start with an old version?

i had this version for some time now.
SU locks up I have to use the TASK manager and for quit.

how do you open SketchUp? Do you have a .skp file and click on it?

I suspect your machine is not up to the task. In order to use an internal graphic card with SketchUp, all drivers must be up-to-date (from the manufacturer) and SketchUp has to be installed by right-clicking on the installer file and choose ‘Run as Admin’. This will ensure that the right supporting Visual C++ files gets downloaded and installed.
Still, why use an outdated version? There is now 2019.3, better working with the latest version of Windows.

tried running as admin… same issue

blank doc… same issue…
freezes!

not just running as admin, it is not the same!.
With the install things get set properly, only…

You can always ‘Repair’ the installation.

try changing some settings in [menu]Window->Preferences->OpenGL

We have a support case with these symptoms at the moment. You may notice that pressing the Escape key gives you control of SketchUp again. Our first guess was that the workspace needed resetting, but that didn’t solve it. Don’t know what the answer is going to be yet.

1 Like

yes pressing esc works.

workspace is reset (using esc) … but still can not make component without program freezing.

Standing by for possible solution to let me make a component

Before you create the component try opening your component window and clicking the home icon to bring up all of the components currently in the model.

Then try to create the component.

clicked…
noting listed (new model)

freezes

So do you ever see the “Create Component” dialog appear ?

nope.

If you hit Enter after right-clicking>Create Component, does that create the component? Is your Create Component Dialog window off screen?

Okay Close SketchUp.

Navigate in File Explorer to:
%LocalAppData%/SketchUp/SketchUp 2018/SketchUp
(You can paste this path into the address bar and then hit ENTER.)

Make a backup copy of the "PrivatePreferences.json" file.

Open the "PrivatePreferences.json" file in a good text editor.

Look for a settings object like this …

        "ComponentCreateDlg": {
            "show": false,
            "sticky": false,
            "x": -554,
            "y": 468
        },

… it should be up near the top of the file.

See if one or both of the coordinates are negative (like mine I purposefully moved it to my secondary display, made a component and then closed SketchUp normally.)

Try setting them to 0,0 so the dialog appears at the top left of the primary display. Ie …

        "ComponentCreateDlg": {
            "show": false,
            "sticky": false,
            "x": 0,
            "y": 0
        },

Save the JSON file.

Restart SketchUp, and make a dummy component. You can drag the window to the center of your primary display if you wish. But be sure to complete the component creation. This will save the new location.

Quit SketchUp normally, so the JSON file is overwritten.

You should be back top normal.

1 Like

I have had luck with Alt+Spacebar+M to grab a window that is lost off screen.

I always forget what that keychord is!

ADD: And I also forget how to force the hidden window to jump to the cursor (it’s press one of the arrow keys.)

1 Like