Crash upon Component creation


#1

I had made a lot of progress in a model and one day in the middle of work, creating components caused the program to crash. I select a group of objects, r.click, Create Component, get the dialogue box, give it a nme and click enter. I get a busy cursor symbol for a few seconds (this had never happened when creating a component) then both monitors go black for a second, the view returns, and Sketchup’s workspace is whited out. The program must be ended by force. If I open the model back up, it acts normally until I try to create a component, then it locks up again. This also happens if I open a new model and try to create a component. Opening the model on other computers does not show this problem. I have had graphics card problems in the past (last year) which were not completely resolved, so this may be an explanation.


#2

I have the exact same problem whenever I try to use any component function with the Components Window on screen. Try closing the window as a temporary workout for creating the component. However, if you wish to browse the model components and open that darn little component window again, it will crash.

(btw my screen doesn’t go blank or anything. the app simply stops responding indefinitely…)


#3

:scream: Can you explain a little bit about what version of SketchUp you have, and type of computer as well as version?

Do the groups/objects have a lot of complex geometry or faces? Would you be able to share a screen shot or even your SketchUp File?

Thanks!
AlexB


#4

Niko, this problem happens regardless of the component window being displayed and it also happens when I try to explicitly save or save while exiting.

Alex, I am running 2015 Make on a 64-bit Windows 7 PC. This problem did not occur in 2014, but I did not start right when I updated to 2015, it took a week or two. The component can be as simple as a cube created in a file with nothing else and it still crashes. The crash also occurs if I open a new, empty file and try to save it.

thanks, guys, for your responses.


#5

Generalities won’t help us get to the root of the problem.

Desktop or Laptop ?
Integrated Graphics Chip ?
Discrete Graphics Card ?
Are the graphics drivers up-to-date ?


#6

I have the exact same problem. SU continues to crash when creating a component. It drives me nuts.


#7

I have just started having a similar problem. I select objects and “Make Component”, and a component axis appears, and I can’t do anything: I just get get the “problem bing” whenever I click anywhere. I believe the normally visible dialog box has become invisible, because if I just hit return, everything returns to normal, but I’ve tried moving and minimizing windows (note that I can’t move or minimize sketchup windows during the problem), checking my running applications under Task Manager, and can’t find any evidence of a dialog box. My sense that it’s a dialog box is further bolstered by the difference of making a component of a group (where there normally wouldn’t be a dialog box): it works perfectly and instantly.

I’m running SU15 15.3.331 64 bit on a HP EliteBook 8740W with stock video and additional monitor and 3DConnexions Space Mouse, though I’ve tried it with the Space Mouse disconnected and it doesn’t seem to matter.


#8

Click create component to get focus on the dialog, tap alt then space then m then any arrow key and now move the mouse around until the dialog appears.


#9

I just found the problem: I’d moved my second monitor from one side of my notebook to the other, via “Screen Resolution” settings on desktop (all this is Win7 Pro btw). The dialog box was created where the screen used to be, where I could never get to. I found the solution here:

https://groups.google.com/forum/#!topic/sketchupissues/2uzq-_ErLts

Thanks Gully! (I can’t think him there, it’s closed). In case the link fails, here’s the info:

Mono,

Sounds like your Component browser is ok; you’re missing the Create
Component dialog.

I just experimented, and I think the system menu Move command will
work. Do this:

From an unstuck state, select some entities to make a component–
anything will do.

Hit the shortcut key for Create Component–the letter “G”

Immediately, before anything else, hit Alt-Spacebar

Hit the letter “m”

Press one arrow key one time

Without pressing any buttons, move the mouse up and down and from side-
to-side. Look for that pesky Create Component dialog to come into
view. Position it with the mouse and click the left mouse button when
it’s in a good place.

You should have it back.

-Gully


#10

OMG, fanfare and confetti! I actually didn’t have to go that far through
your instructions. I always selected and r.clicked to create components.
Trying to follow your advice, I selected some objects and hit G and the
component dialogue box was right there where it should be. I tried again
after that to select and r.click and the Components box was there again.
Maybe using the keyboard shortcut has an added step of checking the
dialogue box settings. I don’t know. I can make components again! Thanks!


#11

Great, glad it worked for you too! It sounds like keyboard shortcuts reset the location somehow, which is actually a little weird and I can imagine problems stemming from that, but until I run into them I’ll just take the win!

Keith


#12

Well, the component creation is fixed, but it still crashes when i try to
save. My workaround it to just leave it open for a few minutes until the
autosave kicks in, then let it crash, then recover the autosave. Oh,
well. Not that big a deal.


#13

Having exactly the same issue… have updated graphics drivers but no change…


#14

@3dldnz what issue? Several issues have been mentioned here.

@bhackett, you never wrote which graphic card you have. By any chance is it an AMD card? If so, try disabling hardware acceleration before saving from Window > Preferences > OpenGL.


#15

Sorry, was replying to the OP about crashing when creating components in SU2016.
Using Win10 x64 with Nvidia Quadro K4100M.

In typical fashion, after having the issue for a few weeks, I tried closing and re-opening the components section in the new default tray and it appears to have fixed it… for now.


#16

This issue still exists… No bug splat, just extreme not responding to force quit.

SU v2016 latest version, latest nVidia drivers.

A solution I’ve found works, albeit kind of stupid, group the geometry first then context click ‘make component’, then adjust the naming etc. from entity info.


#17

You’re talking about a different problem. Please read the thread before more carefully


#18

This was a great work-around, but in Sketchup 2017 it’s not possible anymore, since the Component Dialog Box will show up in any case. Sketchup fails the make their most important feature work properly.


#19

Is there anybody here who could explain why the hell creating simple component in SU2017 takes so looooong? Or sometimes, randomly - SU-bloody-2017 crashes during this simple process. It never happened in SU8! Where is that improvement?


#20

Hi.
I SOLVED the Crash problem when creating components.
Because the CAD or Revit file imported contain too many blocks; or sketchup file contains too many components, I assume Sketchup 2017 couldn’t make more than a certain number of components.
Step 1 - I open the CAD file, save as a new temporary file on desktop. Then explode everything in the CAD file. Save it.
Step 2- Create a new sketchup file and import that temporaryCAD layout from desktop into clean new sketchup.
Now component creation is working fine.
Hope it will help you.