How to open models from Google Drive

googledrive
attachments

#1

Even when it’s a feature mentioned on the app description, I can’t find a way to open models from the google drive app.


#2

See this page in the SketchUp Mobile Viewer User Guide:
Accessing Your Models in SketchUp Mobile Viewer

… and scroll down to the section labeled:

Opening a SketchUp File That’s Attached to an Email (and/or opening SketchUp files directly from any other app, e.g. the Google Drive app)


#3

Those are the exactly steps that I’m been trying since the beginning, but Sketchup do not appear on the list of apps of options to open the model with. Opening attached models from mails is not a problem, works fine. The deal here is the Google drive app models, because all my teamkorw use Google drive in order to be updated all of us all the time. I’m using an iPhone 6s 64gb with iOS 9.3.1


#4

I’m having the exact same issue. There’s no option to use Sketchup as the app to open a .skp file that’s selected in Google Drive.

This is on the latest iPad Pro – iOS v 9.3.2 with 85GB available.

Attempts to transfer my model via iTunes also fails. It works for a very basic model, but not the one I’m interested in.
And I can’t use 3D Warehouse to host my model, because it’s above the 50MB limit.

I can send the log files and the model if you’re interested. But if Google Drive doesn’t work as advertised, please provide the instructions for requesting a refund.


#5

Hello, I am facing the same issue. I cannot select Sketchup Viewer to open .skp-files from Google Drive or eMail for that matter. Is there any trick or procedure I need to follow to have the Viewer registered as an app capable of opening .skp-files from e.g. Google Drive on my iPhone 6s 64GB iOS10?

Thanks in advance!!
BR, critchm


#6

… and …

The following website …


says:

So my 1st question is did you scroll the list to be sure that SketchUp is not there ?


#7

Hello Dan, first let me say thank you for your reply.

I did scroll to the right, I even hit ‘more’ and did the same on the second row of action but Sketchup Viewer is not an option. In Google Drive I even tried different ways to open a file, first by simply clicking on it but secondly by clicking the three dots next to the .skp file and then selecting ‘send copy’. Unfortunately the Viewer is still not being presented as an option.


#8

I added a screenshot:


#9

Hi Dan, do you have any idea what I can do to have SketchUp available through Google Drive or any other app?
Best, critchm


#10

No as I do not use an iPad, and cannot read the plist file for the SketchUp Mobile Viewer.


#11

Hi All,

We have been tracking this issue since it was originally reported, many months ago. Based on our investigations, we believe the issue to be on Google’s end, not ours. See this thread on the Google Product Forum.
As a potential workaround, our tests have shown that the Drive app suggests SketchUp Viewer as an Open In option only if the SKP file is uploaded to Drive using the Drive desktop app. When files are uploaded to Drive via a web browser, the Open In function fails to suggest SketchUp Viewer as an app to open SKP files. :cry:
We’re monitoring the status of this issue and will report back if/when we hear some good news.
In the mean time, sincere apologies for the inconvenience.


#13

Hi Mike,
This is not limited to google drive. The issue is that sketchup viewer does not show up in the “open with” menu
In google drive, email or any other app that I’m able to save a sketchup file in.
(For example I saved it in evernote - from there I can click on the file, get the open with menu and sketchup is still not there)

This is definetly an issue with how the sketchup viewer app is registering with iOS and not on the google drive side


#14

Here is what you have to do if you use google drive to organize your sketchup files but want to be able to view them on iPhone without needing to go to a computer and drop them somewhere (requires Dropbox)

  1. In google drive click on the dots to the right off the sketchup file and select Open In --> Import with Dropbox.
  2. Select a location in your dropbox folder and save it there.
  3. Go to the dropbox app, Find the imported file and click the down arrow to the right of the filename and select rename. Add “.skp” to the end of the filename (google drive strips the extension when it exports the file - convenient huh?)
  4. Now in the sketchup app go to open a file from dropbox and you should be set (assuming you have dropbox configured in the sketchup app)

Not the easiest way to do this, but if you are only on your phone, it will technically work in a pinch.


#15

I think that someone at Trimble should not underestimate this problem…
Google is already keeping the keywords “Sketchup Viewer” “open” and “GoogleDrive” as most suggested ones…
This topic is already one of the most read ones, if not the TOP one… (beside the “how to open a .skb file”…).

This is something which seems bothering a lot of Sketchup Mobile Viewer customers (yes, CUSTOMERS, as we all paid for this application… and someone also PAID twice, if using it on different platforms such as an Apple smartphone and an Android Tablet, or viceversa).

And this is still “under investigation” ?

I’m a F1 fan and when something happens over there, “under investigation” takes between 30 and 300 seconds…

This is a KNOWN ISSUE since more than one year ago…

At the end I’d to register to be able to add my 2 cents, but the “read counter” should have given an idea of how much interest this is causing…

Let’s pretend the 3.482 read (as it is now) come from the same users at least 5 times… it makes a total of almost 700 users looking for an answer on this…
Let’s pretend 100 times this is caused by previous posters coming back… it’s still almost 600 people looking for an answer on this…
Let’s pretend HALF (???) of them came here by mistake… it’s still around 300 people…

300 complaining people…

Who use the “word of mouth”…

Worst thing is that if I’ve been the only one to come here 5 times for the same reason, the possible complaining people number is 3.470…

Just think about it.


#16

In the meanwhile, I’m mirroring my google drive data on Dropbox, which
"open" function works fine.

Thanks!

El El jue, 27 de abril de 2017 a la(s) 12:20 p.m., Michele <
sketchup@discoursemail.com> escribió:


#17

[ Moving thread to new Technical Problems > Viewer sub-category. ]


#18

@DanRathbun Thanks


#19

Any reply about a refund? This is false advertising and awful customer service.


#20

It is not false advertising but an intended feature that now works only in a subset of use cases (when uploaded from desktop app) due to extraneous cause:

[quote=“MikeTadros, post:11, topic:23340”]
Based on our investigations, we believe the issue to be on Google’s end, not ours. See this thread on the Google Product Forum.[/quote]
If Google Drive integration is essential to you (as it seems) and you are not satisfied, I recommend contacting the Sales team for a refund. I’m not sure about how refunding works through app stores, see the contact email at the bottom in the app store(s) or the desktop support contact.


#21

I’m not sure how stating that a feature is present when it is only “intended”, isn’t false advertising, but anyway, all my models are uploaded from the desktop app and they don’t open, so now you’re doing the exact same thing.

Whose fault it is, is irrelevant, don’t put the feature in the description if it isn’t true. Maybe there is some specific scenario where people have been able to open models uploaded from the desktop app, but your blanket statement that it works is outright false.

I have already made contact with the App Store regarding a refund. I’m not sure why you’d assume I hadn’t. I’ve also submitted 14 apps to the App Store, so I don’t need advice on how contacting support works. On the other hand, there is no way to contact Trimble with this issue that I could find. Their support for the mobile app is non-existent and the main support website doesn’t even allow you to contact them about a general issue, or anything remotely related to the issue I have. They force you to choose a specific topic, all of which are related to the desktop app. Thus my comment about the poor customer service. I wrote on this forum in case a solution had been suggested to the user, not to be placated with irrelevance. Thanks anyway.