Eyedropper Broken in Layout SU22?

Did the Eyedropper tool behavior change in Layout 2022?

It used to be that the Eyedropper would assume the properties of whatever you clicked on, regardless if it was nested within a group.

Now it appears that Eyedropper assumes the properties of the group itself?

I feel like the prior behavior was more in the spirit of the tool. If I am working within a particular group, it is laboursome to exit that group in order to sample the sub-elements within a different group.


Just looked at this with my 2022 and it doesn’t appear to be broken for me…

Are you trying to sample a color?

If so then are you aware that the Color Sampler (eye dropper) is a different tool to the Style Sampler (also an eyedroipper)

Style is in the top menu bar. It will only sample the object you select - can be tough if there are things overlapping it (especially text!!)

Sampling colour can look through groups/objects, and it must be done using the eyedropper tool in the Colors Tray.

It’s confusing having two tools with the same icons but with different behaviours. They at least need to put a little “S” next to the Style eyedropper and Paint bucket icons, I think, or change the colors of the icons slightly…?.

1 Like

Interesting… I did not know there were two eyedroppers -that IS confusing! And I have been using SU\LO since 2007! I don’t use icons but keyboard shortcuts so when I went to investigate, sure enough… there are 2 listed.

Strangely, you can’t access “Other/Pick Style” at all from the menus?

So it appears that with “Tools/Style”, you pick the style first then apply it to another object and with “Other/Pick Style” you pick the object first then click on the object you want to sample from. Both seem to be able to select styles nested within a group, which is what I was struggling with, so thanks!

Also, both have the effect of changing the current style in the “Shape Style” dialog to whatever you pick, which I think is wrong. One of them, probably “Other/Pick Style” should allow you to keep drawing with the style you had selected in the “Shape Style” dialog (if anyone cares).

You’re not alone - lots of people get caught out by that one.

Another small point of confusion is that “Style” means slightly different things in SketchUp (where styles are created, saved and applied to scenes) and LayOut (where styles are an assortment of visual properties applied to shapes, edges, text, etc)

Improved terminology and symbology are probably the solution.

Thanks @AK_SAM and others.

Actually, I re-discovered the behavior I originally found troublesome (but could not describe very well!)

Check this out.

In 2022, when you try to match properties, the eyedropper tool does not seem to understand what is on top of what. In the snip below, you can only sample the green circle where it is over nothing. If you try to sample the portion of the green box that is on top of the red square, YOU CAN’T! it samples “through” the green circle to the red object.

This does not seem like the desired behavior. What if there is no portion of a sample object that has nothing beneath it? It becomes essentially un-sample-able.

Nov-11-2022 18-05-46

Well today I’m trying to use the Color Sampler (from the Colors palette) and it’s just not working!

I think it is truly bugged.

I’ve tried it with a very simple sampling operartion of just havng 3 colored boxes, and it’s not working

Style sampler sometimes works (it doesnt sample the color either), but not the color sampler. There seems to be an issue even activating the tool as the icon changes when I hover over it (eyedropper symbol), but when I click the tool it doens’t do anything (no tool tip)

@colin the bug is that the color sampler tool doesn’t work when LayOut is opened on a secondary monitor.
(I am using a Win11 and Nvidia 3700ti laptop with a hdmi connected external 4k display)

I will try to match that setup. While I’m doing that, does it make any difference if you set the two screens to the same scaling value?

Yes, it does make a difference.

Laptop 125%, External 150%: Only laptop works

Laptop 150% (recommended) and External 150% (recommended) neither work. The laptop samples the paper and its light-blue gridlines, but not the objects.

Laptop 125% and External 125%: Only laptop works.

Duplicate displays: both work ok.

I haven’t tried restarting my PC or LayOut between these (but i did open a new layout doc).

By duplicate do you mean the same single desktop on both screens? Not surprising that would work.

I think I have myself set up to try similar tests. Will let you know what results I get.

Yes, duplicated at 125% same content on both screens.

The laptop screen is an uncommon resolution at 2560x1600 (edit)

I feel like this has been working okay in the past becuase i think i would have picked it up by now…but that could have been months ago.

@DaveR can you remember the outcome of this old case?:

As I try to reproduce the steps, I get black when picking up a pixel from my second monitor, so I can’t even get as close to working as AK_SAM does. Once we get past that part, do you know if there is a LayOut issue with HiDPI monitors?

@trent you may have ideas too.

Sorry. I don’t remember this from before.

Perhaps @ksarch_CDG_TSA_2 will remember what fix you gave him!

I do see that the ey dropper doesn’t seem to work when I move the cursor over to the second display.

I don’t remember getting anything to work. Haven’t tried using that feature in a long time.

I’ve seen cases where mousing around the current monitor is either very slow to update the color in LayOut, fails to update at all. But, a click will immediately update the color.

Hi @colin. Just wondering if there has been any revelations on this? I am running into this “bug” a lot!

So I guess this is not on anyone’s radar @colin ?

SketchUp 22 will not be updated or fixed to repair issues.