Extension Manager won't show anything


#1

When I turn on extension manager I get a blank screen. There was an exact same post about this in Jan but couldn’t see any solution. Does anyone know what I should do?

I have tried reinstalling with admin but still get blank screen.


#2

Can you reach the Extension warehouse in a browser?

https://extensions.sketchup.com/


#3

Yes. I can get to Extension warehouse without any problem.
windows→extension warehouse→Opens a browser and works fine.


#4

Quit SketchUp.
Try to delete the webcache:

C:\Users* YOURUSERNAME *\AppData\Roaming\SketchUp\SketchUp 2018\WebCache

Does the 3Dwarehouse dialog gets populated or is it also empty?


#5

Which files do i delete?


#6

you can delete the whole folder.

If in doubt in these situations, duplicate the existing folder at the same location (foldername copy). If deleting the original causes any trouble, rename the copy.


#7

I closed sketchup then delete the WebCache folder, reopen sketchup, Windows→Extension manager but still I get a blank screen. Any other solutions?


#8

right click on the blank extension manager dialog screen, hit View page source, does it show something?


#9

The only thing I see is …


#10

mmh, couple of things I always check/try:

The right procedure is to right click on the downloaded installer file and choose ‘run as administrator’
How you logged in does not matter.

Check the other dialogs that uses SketchUp domains:
3D-warehouse, Welcome screen

Are they also blanco?

I have seen issues with graphic cards causing interupts that affect the good working of the network adapter, due to (to low) power capacity of the system.
This can be tested by using the integrated graphic card only.
Try updating the drivers for both cards, as well.


#11

Hey Thanks for the advice. What I meant was I did right click the installer file and chose ‘Run as administrator’.
For 3d Warhouse there is proper things written in the dialog.

My machine is the Razer Blade 15 2018 with Geforce 1070 Max-Q so should have the most updated drivers installed, but will check.


#12

So it is a laptop. The fact that it is ‘New’ doesn’t imply that it uses the latest drivers, for they can change on a monthly basis.

Check if you get different results with a wired connection.
Check if you get different results wile ‘on the grid’ (loading)
Check in the NVIDIA control panel, in the tab ‘Program settings’ to get SketchUp only to use the “internal graphics card” , thus, disabling the 1070(!)

pinging @Steve, but I guess it is weekend…


#13

I just figured out what was the problem. It was my Windows 10 setting. I had ‘One Drive’ on which caused the extension manager to not work. Not sure about the detail… I turned it off and extension manager started working. Finally. Thanks to mikewayzovski for all the help!!!


Extension Manager BLANK!