Extension Manager window is blank & Preferences doesn't display and extension box

I’m on Windows 10 (x64). Nvidia GeForce GTX 1060 with Max-Q Design.
I recently downloaded SU 2021 and ran as administrator and was in the process of downloading extensions and have encountered two problems.

  1. The extension manager window is blank
  2. Under preferences I don’t have an ‘extensions’ option to select. I’ve attached screen caps.

I managed to download a couple of extensions … one is Trubend that works.

I opened SU2018 to check if there was the same problem and the extensions manager window is also blank.

I’ve read past posts going back to 2016 and have tried a number of fixes that were suggested by the SU team like repairing Sketchup 'as administrator, turning off OneDrive, updated my graphics drivers … restarted SU, also deleted the webcache for both and restarted my computer and the problems still persists.
Please help! I’ve spent and entire day trying to fix this issue.

There is no extensions option in Preferences.
Did you try signing out of sketchup, closing, opening and signing in again?

Box Thanks,
I just did that and it didn’t work.

very new to Forums in general and not sure if you got my reply Box. I tried what you suggested and it did not work.

Yes I saw your reply, but I had nothing more to add.
What about antivirus and firewall, perhaps they are blocking.

Not a tech wiz here so I’m not sure what you mean. Do you mean to disable my firewall and antivirus? or are you referring to settings in either?

Well, yes, trying to track down what is stopping things working requires a bit of trial and error, so yes, it may be either your anti virus or your firewall that is causing the problem.
Therefore turning them off would be a way to see if either is the issue, if that turns out to be the case then it might be adjustable within the settings of one or the other.

I’ll ping @colin on this also as the team may have some further insights into your problem, it is after all a fault that needs correcting.

Box would definitely appreciate that. I’m just looking at my firewall and anti-virus settings now.

Thanks, I have been reading this, and was seeing if the first ideas helped.

3D Warehouse and Extension Warehouse cache their files here:

%AppData%\SketchUp\SketchUp 2021\SketchUp\

You can copy and paste that into a File Explorer window. In that folder is a WebCache folder. Trying renaming or deleting that folder before opening SketchUp again. The folder will get regenerated, and hopefully solve the blank window problem.

@colin Thanks
I didn’t see the WebCache folder at that location but did find it @ %AppData%\SketchUp\SketchUp 2021 & %AppData%\SketchUp\SketchUp 2018

I deleted the folder and restarted both programs and the extension manager window is still blank

@Box I just went into the permission in my antivirus and both programs have no restrictions

I was one folder down from where I was thinking. Try this path:

%AppData%\SketchUp\SketchUp 2021\

When this started happening I searched the forums and found others having the same issue so I followed suggestions from other SU Team members which included deleting the WebCache. Unfortunately It didn’t solve the problem.

GOOD NEWS is that after forcing a driver update though my computer’s manufacturer’s Asst. App (Windows update told me everything was up to date) I can now see the extensions in my extension manager.

BAD NEWS - I’m now getting a ‘error loading’ message at startup for all the extensions I downloaded and installed. I click OK and the extensions appear on my desktop. Screencap attached.

I’m an occasional user of SketchUp (using AutoCad mostly) so I’m not totally up to date on any changes to how extensions / plugin’s are installed.
In older versions didn’t they have to be installed through the Preferences dialog box? I’m not seeing that option anymore in that dialog box.

For several versions, they have been installed using the Extension Manager Window, not Preferences. But they are downloaded from the Extension Warehouse using its window or else separately using a web browser.

I hadn’t heard of Follow and Rotate, but according to their SketchUcation page, it only works with SketchUp 2016 and earlier:

Never rely on this!

@slbaumgartner Steve, its obvious I’m an occasional SU user. My confusion came from online videos.
Thanks for the update.

Thanks Colin. My frustration levels were pretty high after many hours of trying to solve the problem.
When I saw the ‘Ioad error’ pop up with the list of all the extensions I assumed it was for them all!

Thanks for your help!

Yeah, there’s a problem that stuff gets put online, not all of it by the SketchUp team, and then it stays there forever while SketchUp moves on. There is also a chronic issue that particular videos may be built around the Mac, the Windows, or the web GUI - each of which is different enough from the others to cause confusion.