Window does not work for Extension Manager (SU2018 Pro and SU2020 Pro)

Hello! I apologize for the mistakes. I know English bad. I have a problem - the Extention Manager window does not work. At that, Extention Warehouse opens. I checked on two versions of the Sketchup program 2018 Pro and 2020 Pro. It does not work in both cases. Help me please.

My system:
Windows 10 Pro 64 bit
Sketchup 2018 Pro
Sketchup 2020 Pro

Hello @strukov_artem, thank you for reporting this. We are looking into it.

Extension Manager is working here in 2020.

When you installed SketchUp did you right click on the downloaded installer and choose Run as administrator from the Context menu? If not, find the installer and use Run as administrator. Then select Repair.

It seems unlikely that both WebCache folders would have a problem, but it could happen.

Go into this folder: %AppData%\SketchUp\SketchUp 2020\

Delete the WebCache folder and reopen SketchUp 2020. Do the same with 2018, in this folder:

%AppData%\SketchUp\SketchUp 2018\

I tried your solution. Unfortunately not working ((

Did you install SketchUp correctly as I asked above?

There was an oddity in your post, where it only just appeared.

I just noticed that it’s extension manager that is blank, I was thinking that it was extension warehouse.

Let’s see if Dave’s suggestion helps.

Hello Dave! I tried your way. Didn’t work. I tried it in 2018 and 2020 - it does not work

your menu bar shows no ‘Extensions’ item…

you may need to instal one before being able to ‘manage’ it…

john

1 Like

Good catch.

Hello John! Thank you for your reply. I have installed several extensions. A line of extensions has appeared. But the extension manager is still not working

This seems to be related to translated versions of SketchUp. What language are you using SketchUp in? What is your system language?

you can check if they are being loaded using ‘Window’ >> ‘Ruby Console’ and pasting in this line…

$".grep(/plugins.*\.rb$/i).join("\n")

are they all showing?

john

Hello! Not connected. On other computers, everything works fine. I have installed the Russian version of SU 2018 Pro and the English SU 2020 Pro. System Windows 10 Pro language Russian

Such a result

plugins work fine. But I can’t install plugins with * rbz extension through the extension manager from my computer now

can you ‘Right Click’ on the Extension Manager window and select ‘Inspect’ [or similar]…

@colin, I can induce a blanc window if I try the Settings Button…

john

right-clicked in the extension manager. Then “Inspect” and this window appeared

that looks like a permissions issue to your temp directory, where SU ‘builds’ the missing content…

did you do a ‘Repair’ on your instal??

john