Extension Manager BLANK!

Seems like many have already brought up this issue, but I can’t find a single clear step-by-step solution to resolve this problem. Yes, it’s the Extension Manager coming up BLANK and I can’t find a way to get it to work. I have a Windows 10 OS, using Sketchup 2018, and everything seems to be up-to-date. Somebody please help, or perhaps a contact phone number to the Sketchup tech support team (I can’t get a hold of them by sending e-mails, and I’m running out of time/patience. Can’t wait indefinitely!)

Hey, Sketchup Team. I have NOT received your respond back yet. Please reply back so at least I know you’re aware of this post.

Hey Mike! I read your comment before and also tried UNINSTALLING One Drive. Disappointingly, that didn’t do me any good. Is there any way to contact the Sketchup tech-support team via phone or chat?

You might have gone through all of this already but these are the things I did hope it helps,

-Install the program as administrator and turn off windows defender or any anti virus software.
-Run sketchup as administrator.
-Allow sketchup or any file in sketchup that seemed related to extension manager through the Windows Defender firewall.
-Disabled one drive so my document, desktop and other folder are not within one drive.

These were the steps that worked for me. Hope it helps.

1 Like

support: Support - Technical Support | SketchUp Help
I allready pinged @steve in the other thread, but @Barry might know something as well.

General contact is here: Contact Support | SketchUp Help I’m not much help off the top of my head on client or Windows, those contacts would be better.

Thanks, Mike.

Also, Barry, I already have my case reported to the Team. I just received a response back from James, but his method was nothing newer than what Mike had pointed out before (deleting the WebCache). I also tried reinstalling SU “as an Admnistrator”, updating my GPU (Nvidia GeForce GTX 970 & 770), updating Windows 10, and even deleted Windows One Drive. Nothing works. Seems like I will need a specific diagnosis by the Team (totally willling to go through remote assistance via GoToAssist, etc.)


One quick question: what version of Windows are you running, what are your language settings, and what version (language) of SketchUp do you have installed?

@Barry Windows 10, English, Sketchup Pro 2018 English version.

I was hoping I could somehow try to bring up the wrong language some how and make it fail… for example, I tried changing it to French on an English install, but the screen shows text in the upper left “Oh snap! blah blah blah”.

The usual reason for windows being blank in SketchUp is about internet connections. SketchUp requires uninterrupted access to the internet for features such as the 3D Warehouse, Add Location, Add License, and Extension Warehouse. To ensure connectivity you may need to adjust settings in your Firewall, Proxy or Internet Security software for your network or computer.

SketchUp needs access on the following ports:
Single User License: 80, 8888, and 443
Network Licenses: 5053, 50530

SketchUp needs permission to visit all of the sub-domains for SketchUp.com, easily included as:

Please see this article for the complete description and list of steps to take to correct the problem of connecting to the Internet through SketchUp Pro: Troubleshooting Connectivity Issues within SketchUp | SketchUp Help

We also recommend accessing the 3D Warehouse through the built in 3D Warehouse Browser and/or your web browser ( https://3dwarehouse.sketchup.com/) instead of the component browser.