Crash when closing a face

SU 21.0.339

Try closing the spiral at whatever end. It can be only closed gradually in pieces.

CloseTheSpiralCrash.skp (492.7 KB)

I can’t as I’m on a phone but first thought is how many segments in the closed loop?

I expect you’re running into the tiny face issue. 12345 exploded edges in a small 56mm by 57mm area. (did you do that intentionally?) I tried welding the edges but there’s so much for SketchUp to do that it stalled. It didn’t crash but I closed it to quit waiting.

Your original model closes the spirals without a problem.

It shouldn’t affect this, but SketchUp 2021 was updated, you could try the current version.

10000 is the limit for a single loop.

1 Like

Here’s a related thread: Healing Snowflake Crashes SketchUp

1 Like

I created this model, because it will be printed in 3D, so it has to be that scale.
I have found workaround myself as I have written in the initial post, so it is not a tragedy. :slight_smile:

I reported it to let SketchUp developers take action whether they find it appropriate.
I removed all the plugins and updated SU to 2021.0.391 (Win), but the model still crashes.

jimhami42 pointed to same issue and it looks it still exists. I think any crash in application should be prevented even with a simple message when a whatever limit is exceeded and abort the operation.

It is not urgent for me to have this fixed, but it would be nice to address it or at least prevent the crash. I hope SU Devs will mange to replicate it as shown below:


I do not get BugSplat with it, just the instant crash.

Btw. The group is scaled down, so the original size is big enough to allow proper triangle sizes I believe. As I have written I can close the loop gradually, starting from the middle and closing next sections outwards.

I guess it is the same place in the code responsible for the next crash. It happened when I trimed the already pushed face.

The internal geometry is still only 28mm across. You could make it at any size, then export STL, and have your 3D print application do the final scaling.

It did crash when I closed the spiral in Windows, but not on Mac. When I saved, it crashed on Mac, but I was able to copy the spiral into a new file, then save that.

spiral2017.skp (1.0 MB)

BTW, it does still crash Windows SketchUp even if I scale it up to 100x.

You mean internal OpenGL geometry?
The internal geometry has radius of 15 meters.
The one defined in the my model is full size and only the scaling transformation is applied to it.

I am glad it crashes for you too.

I meant if I go into the group and measure the width of the spiral, it’s 56.75mm across. But actually, I couldn’t get a case where the internal raw geometry was big, and the outer group or component was small. My Dave Method skills need improving.

I took your file, exploded it, scaled it to 10x, and tried to close one end of the spiral. I sent the bugsplat in, and will give my colleagues the file for them to test.

1 Like

I found that it crashes in SketchUp 8 as well, so it’s not a recent issue.

1 Like

If you select the group and reset its scale, you will see that internally it is 30 meters in diameter.

Indeed it looks it is the old issue as jimhami42 pointed out.

I found Tricia’s bug report, and added your file as another example, and linked to my bugsplat.

Unfortunately it is not possible to work with the resulting face, even if it is scaled 100x. SU instantly crashes when cutting it.

The good thing is that I generated the model with a Ruby script, so I can make it less precise. I hope it will be editable then.

What role does the spiral have in your 3D print? If you get it to fill, it will still be a single flat face, and if you give it thickness and print it it will still be equivalent to the outline without the spiral

The model has two independent spirals, outer and inner. They will be printed from two different materials.

I reduced spirals complexity in the script. It made SketchUp close the faces alright. Cutting the face still crashes SU regardless of scale, so it may be a different issue.