Sketchup shuts down after pulling up a curved shape

I have a long face with a lot of curves on one side and want to pull it up to 3d. I cannot pull the whole thing up without sketchup 2018 (and have tried 2019) crashing out, no bug splat, just shuts itself down. Sometimes I can’t even close up an open sided face with all those curvy lines without a bomb out. I have tried dividing it into smaller and smaller pieces to pull up, and can sometimes pull up a piece before it bombs out again. The linework was originally created in autocad and imported. The piece in the model is part of a much larger landscape model.

Wiggle Edge.skp (3.5 MB)

I have updated my graphics card driver, tried setting the driver for performance rather than quality, run sketchup checkup which says it is happy with my set up, my pc is hardly using any resources while editing this file. I can orbit round quickly. I’ve tried fixing and purging. I’ve copied it onto a new clean file. I’ve had huge landscape models full of trees which take ages to reload and chug along like a snail but still not bomb out except once in a blue moon, but this seems like some hopeless problem with all the curved lines. Any advice about why these curves are creating such problems gratefully received!

Do you need the thin bit or is it one solid piece you are after?
By the way, you should look into how layers are used in SU, you are using them incorrectly.

Some of the linework on the right side was on multiple layers. If you delete all the layers and put everything on layer 0, flip it over and look at the bottom you will see a large part of the narrow section is not a closed surface. I attempted to close a small random section and had an immediate crash. Why I do not know.

There are a mixture of issues, multiple layers, lonely vertices, tiny edges and too many segments. All of which combine to make it fail.
There are over 12000 edges and if I remember correctly there is a 10000 segment limit for a single loop, this is banging up against that limit.
The inner offset is a problem, remove that and the shape will behave but put it back and it crashes.
In my opinion the import has brought in too many segments for the curves to cope with. The same shape drawn withing SU would have fewer segments and would be less likely to fail.

So, try it without the offset, I managed that quite well, removed lonely vertices with fredo tools, deleted the layers and put all the geometry back to layer 0, welded the curve with curvizard and push pulled a solid shape. Then I tried to offset the wiggle and it crashed.

100 % with everything Box said. I was able to get it done but got the “spinning beachball of death” when trying to pull the big face on the left.SketchUp didn’t crash but I went ahead and force quit it. Then divided that big piece into three sections and got it done.

Looks like I need to tool up a bit more and change my workflow. A lot. Plenty of things to try and looks like I haven’t broken my landscape down into manageable enough chunks. I do need the thin bit unfortunately, but that is probably even trickier, since it had both edges with so many curves. Hmm. Thanks for your help!