Sketchup suddenly closes while using push/pull

Whenever I use “push and pull” the program shuts down without reporting any error. I reinstalled the program and changed opengl settings but the problem is still there. Can anybody help me pls? thx.

Could you share the .skp file so we can see what you are working with?

ebmodel.skp (2.7 MB)

I was able to download the model and push pull any part of it without issue. I hope you can figure out what’s happening on your end to fix this. Sorry I can’t help beyond verifying the model seems to be fine.

1 Like

Try moving your model closer to the axes. Currently it’s over 2.5 Km away.

Another possible problem is the ridiculous number of short edges in that last contour line. The others that I’ve look at aren’t like that.

Is there any chance you have the contours without the building and other outlines included? Those outlines are going to make raising your contours a lot more work.

2 Likes

actually this problem has happened before while i was working on this project. restomodel.skp (7.1 MB) i was trying to raise the walls and sketchup closes again and i haven’t use the program since then. but now i saw the problem is still there. I’m not sure the problem is with the model. am i doing someting wrong?

Not sure where the problem is exactly. It closed on me while I was doing something else to it. I moved the model to the origin and it behaves fine.

1 Like

I did that too but it still keeps closing

Try updating your graphics drivers and do a cold reboot of your computer. Then try again.

You mentioned you reinstalled SketchUp. Did you right click on the installer and choose Run as administrator?

yes i uptated the driver and I ran it as an administrator while installing

Right click on the installer and select Run as administrator?

I have to think it’s a hardware thing since both Monospaced and I aren’t having any troubles with it on our computers. Something’s different on your end than on ours.

Does SketchUp close whatever you push-pull, for instance if you draw a triangle or rectangle and try to push-pull that? I am wondering if one of your dense contour edge loops exceeds the number of segments allowed on a single path (I think it is undocumented, was it 10 000?).

3 Likes

No I can raise simple geometric shapes but i encountered this problem only for 2 times and it didn’t happened before. In the first time i was encountered this problem when i was just tried raise the walls and model was so simple and small. If the problem is due to the contour density, does this explain the previous error?

Someone who had the same problem wrote that the problem was caused by the material, but I did not use any material in my models. I cannot understand where the problem is caused. If I format my computer, will it be corrected?

Too drastic, and possibly not helpful. You are on a subscription. Have you tried it with version 2021?

I have no problems with the model you posted. Are you running any extensions/plugins?

1 Like