Arcs and circles shuts down sketchup


#1

I just installed “arcs and circles” from the warehouse and when I attempt to draw the minor axis of and ellipse, sketchup closes.


#2

Could you be more specific about what you installed, where and how you got it? I can’t find an extension, model, or plugin of that name. Also, what OS and what version of SketchUp are you using?


#3

Okay, I just installed Arcs Circles + by Didier Bur. It seems to work without blowing up my system, although I’m surprised and disappointed that you can’t inference the axes of the ellipse along the system axes.

Perhaps you had not considered how easy it is to make an ellipse using SU’s native tools. Just draw a circle and scale it along one axis.

I’ve got an Intel i7 machine with 12Gb of memory and a GeForce GS530 with 4Gb running Windows 7 and SU 2015 Make. The extension ran without a hiccup. What have you got?

-Gully

Update. After some experimentation, I’ve been able to reproduce the issue rather consistently now. As soon as you draw the Minor Axis longer than the Major axis (even before you click to finalize it), SU shuts down. No bugsplat, no nothing. Just poof–SU is gone.


#4

Check if there is a deficiency with the graphics driver. In SU, go to Window > Preferences > OpenGL and disable hardware acceleration. Does the plugin function now? If it does, try updating the driver.


#5

It appears that Didier Bur has not updated this extension since 2013. My guess is that it has Ruby 2.0 issues that remain to be addressed for compatibility with 2014 and 2015. There are several comments in the Extension Warehouse about it crashing them.


#6

it’s call “DBUR_ArcsCircles_v2_0_1.rbz” and I downloaded it from the extension warehouse.


#7

Yep, it stopped shutting down completely when I ran win8.1 “check for program compatability”, but it’s still not working right. I wish some would understand that most of the time when using curves, either ellipses, hyperboloids, or other, it’s usually just a sector of the curve that’s needed. I really need to use only 1/4 of the ellipse. But can’t figure out how to cut it up. Mine will to draw on the Z coordinate. The X and Y seem OK.


#8

I have an ASUS Q301L laptop. 6 gig i3 with win 8.1.


#9

I’m designing a pontoon houseboat which has a front end that tapers in an ellipse. So the side walls follow an elliptical function from 15 ft from the front to 8 ft high.