Instant crash when raw geometry of dwg import is manipulated

Absolutely (in theory) the most simple printing job I have ever been given to do! A spiral printed to a thickness of 1mm - and the client supplied the CAD. Two minutes to import into SU make it solid, export an stl and print. That was an hour ago! I am stumped.
Imported the dwg, exploded the outer shell as usual, all good. But instant crash - no Bug Splat - when either exploding, attempting to edit the raw geometry (as a whole), or using Enroth’s Weld or Face Creator. I can copy and paste the whole drawing leaving off a few edges, but a crash occurs when I add the last edge to complete the drawing.
There are 17,000 edges the file is under a mb - not huge!
Any ideas on how to work around this?
The attached file has the original component plus extracted raw geometry waiting for the last line to be added - at which time it will crash!
Daniel_Spiral_Design.skp (1.9 MB)

Try importing it at a higher scale. as it is the segments a mixture of too long and too small.

I found if you remove the very center and rebuild it with less segments it will work.


Had tried that after I had managed to extrude it by splitting it in the middle, and it was looking good (now know why), but when I joined the middle bits it crashed. After your demonstration went back to square one rebuilt the middle and then extruded. All good - thanks very much for the lesson.

Now I’m confused!
Really wasn’t happy with the finished article. All I know about electricity is that I shouldn’t stick my fingers in a light socket (again), but the variation in the thickness (width) of the line doesn’t look good to me. So I thought I would build one (happens most of the time when I get dwg files to work from) - should be quite simple. It was - 2 spirals offset, keep the edges to around 10,000 - but! The same disappearing trick occurs when I attempt to make a face by connecting the spirals. Perhaps if reduce the edge count everything will be fine - but still my confusion will remain.
This is a small file, only 10,000 edges and no faces. Whereas I can happily work on another model I am finishing which has 21,3071 edges, 12,2852 faces, and is 30 mb. Why is the spiral a problem?

Because as @sWilliams pointed out if the single loop goes over 10,000 it will crash.

If you are still struggling with this, a simple fix dawned on me.
If you make the spiral from separate components you can alter the number of segments as it gets tighter and remove the single loop issue. I did a few tests and every single loop version had problems, even to the point that you can create the shape, but it just won’t save or export properly.
I made this quickly as an example, it’s only three splits so the changes in faceting are a bit course, but I’m sure you’ll see what I’m getting at. I also made it with 1mm as a meter, this exports to a correctly sized .stl when you choose meters in the export options. And will print as one object.
Component Spiral.skp (1.5 MB)

Ahh! The “single loop” bit escaped me. Cheers.

Champion. Thanks, and happy New Year.

There you go. Right spot (I hope!)
A postscript on this issue: Printing was not possible as the profile being just 2 layers (actually sliced as 1 but the printer made 2 passes) caused the ends of each segment to become rounded and not actually butt squarely when sliced. I tried combining the segments / groups in a couple of other programs as well as starting from scratch in Blender (which I hadn’t used for a while). I was using the combined stl in all of the rebuild attempts, and decided to import this into SU to try to see if I could detect why 1 join was successful but the others not. Didn’t consider that SU might crash with the edge load of the combined drawing - but it didn’t! So,with a few crashes along the way, I have ended up with the whole spiral in one piece. Haven’t done any numbers, but stl’s will always have way more edges (and generally makes a bit of a mess - which it did), and so not be reducing the continuous thing. Why would the re-imported stl be ok?