Can't purge model with SketchUp 2024

Ever since updating to SketchUp 2024, when I try to purge a model, it doen’t even produce a bug splat, but just closes. Is this a known issue and when will it be resolved? Thank you.

Don’t know if this is a known issue.

Are you able to share the problem file?

Hi, I had a similar issue; SU2024 just seemed to go into a loop: eventually I did an alt+ctrl+delete to force it closed & went & purged in SU2023

… just tried again on my laptop, & although it took a few minutes, it worked. So odd.

I haven’t seen any cases in which purging didn’t work at all. I’ve purged some models for others that were grossly overweight. Purging took a while but it did work. Wound up purging better than 80% of the components and materials and the remainder were still morbidly obese.

The models or the users?

2 Likes

Well, I’m overweight and SU’s 24 purge works. But I’m on a mac so maybe it’s different on a pc ? :clown_face:

I can’t say anything about the users, I only saw their SketchUp files. :wink:

2 Likes

:smiley: well, I’m getting overweight just sitting around waiting for the purge :wink: It all sounds a bit like a famous Molière play…

Anyone tried my extension https://sketchucation.com/pluginstore?pln=PurgeAll
It lets you choose what type of thing is purged and reports the results…

6 Likes

It’s the only way I purge models, especially for others because it’s quick and it gives a report to show how much purging was done.

1 Like

That’s also what I usually use for purge.

1 Like

Hi Paul,

I’ve attached a link to my model. It’s around 80Mb. I haven’t had purging issues before SU 2024, apart from the occasional bug splat. So far, I’m also noticing a slower load time in SU 2024 and today, it would open, then freeze as it was still loading tools and plugins.

Curious to see if my model shuts down if you try and and purge it.

Many thanks for your time.

VA_SKP_ECAMPUS FLOOR PLAN.skp

It loads normally for me, and purges in a blink of an eye. Both native purge and Tig’s Purge extension.
I can easily navigate and fly through the model and scene changes are instant.
My only comments would be you should turn off profiles and someone left some glasses out on the floor near the barby for someone to stand on.

It could be an Enscape issue, which I don’t have.
Oh, there is a little incorrect tagging.

Hi Box,

Thanks for taking a look at it. Forgot I had brought in those glasses :laughing:
Tig’s extension purged it no problem, but seems that if I try to Purge via SU’s Model Info - Statistics, it shuts down.

If you could, could you please explain to me what you mean by incorrect tagging? I’ve seen these comments before, but not sure what I’m doing wrong? Thanks so much.

All geometry should remain Untagged and only groups, components, dimensions etc get tags. If you tag the actual geometry you can get issues with the wrong things disappearing when you turn off a tag, and worse still geometry interacting with hidden geometry, possibly deleting things or just plan messing things up.
I didn’t look hard at tagging in your model but here’s a quick example. I triple click this area to select all connected and nothing shows in the Tag list, meaning there are multiple Tags involved in that selection of raw geometry.

Tig’s Default Layer Geometry can work through your model and correct it.

So is it incorrect to triple click eg: a wall to make it a group, then place it on a Wall tag? By default aren’t you picking up all the edges and faces to make it into a group? I am so confused. Have I been creating groups/components incorrectly? Thank you for the link to Tig’s Default Layer Geometry. I will definitely check it out.

Nothing wrong with triple click, make group as long as the geometry hasn’t been tagged.
But even if it has you can change it to untagged while you have it selected, then Tag the group.

It is possible that you exploded a group and then made that geometry part of a group with other geometry. When you explode a group the geometry inherits the group tag. If you have reason to explode something that is tagged, while still selected change the geometry to untagged.

I may have exploded a wall, can’t remember. I didn’t realise that geometry has to be untagged. I’ll make sure that I check this in particular moving forward. Thanks so much for explaining this. i greatly appreciate it :slight_smile:

The model seemed to work/purge okay for me. I did notice a few things that could cause problems.

Some reversed faces:

A Face Me tree going through a wall:

Screenshot 2024-04-19 214922

And a couple of hidden items floating around… like the kitchen sink and pears on the table:

I had to stop looking around your model because I had an eerie feeling I was being watched...