Sketchup not responding after "Purged Unused"

I have a pretty big skp file (about 550mb) and I am now trying to do a Purged Unused, as I haven’t done that for a while.

When I do that however Sketchup stops responding “(Not Responding)”. I left it running for 30 minutes but it didn’t complete, so I don’t think that giving it more time would help, so I had to force close the application. I tried this 3 times with the same result.

I have a new PC with an i7-12700k and 32GB of RAM on Windows 11, and everything else is running smoothly.

Any suggestions?

Share the skp file so we can see what you are working with. Upload it to Dropbox and share the link. Are you still using SU2018 as indicated in your profile?

I’m guessing it may have had a lot of components to purge. Maybe try purging just the components first.

550mb is a huge file. Most of mine for a fully detailed custom home on a sloped site are well under 100mb.

1 Like

No, I am now using 2022.

Unfortunately I can’t share as it has a lot of objects which I purchased in it.

Are there any extensions which can do the same job?

How can I purge just the components?

If I go to the components panel I don’t see this option, and if I click the “statistics” tab everything shows as 0 and the panel seems frozen (scrollbars do not work).

You could share it privately in a message to me.

If you are looking at the In Model components you should see an option for Purge Unused in the Details menu to the right of the Search field.

In the components tray, click on the arrow on the right and select purge.

Thanks for your help. Doing Components and then Materials separately worked. Now size dropped to 420MB.

That still seems huge.