3Dconnexion on Mac Sonoma

Has anyone out here been able to sucessfully install 3dconnexion software on Mac OSX 14? I am trying to get it installed before I stream at noon, but will have to do it without a 3D mouse unless someone has an idea of how to get their installer to work.

Nope, by the way, will you be presenting with SU 2024 this evening(UK)?

That is the plan!

Cool, look forward to it and of course the comments.

Really!? You can’t use a Spacemouse with Sonoma at all? That could put the brakes on my plans for a machine upgrade.

OOOORRrr… you could give it a try NOW and let me know how you get it working!

hey, don’t forget to update your profile, it’s important to know what version of macOS and sketchup you’re using :sweat_smile:
(and that, kids, is how you can get banned. poke the admin with a stick. don’t do it at home.)


Someone asked the same earlier, but I don’t know if they’re using Sonoma (because you know, incomplete profile :upside_down_face:

1 Like

I’m still hanging back on 12.7.4 and an Intel processor machine. One of the benefits of trailing edge technology is stuff that works. Many factors are really pressing to move on to Apple Silicon now though.

1 Like

Yeah… I got the new driver… but the installation hangs about halfway through… waiting to hear back from support but I figured i would check here in the meantime…

Also… how do I “update” my “profile”?
:laughing:

well…

:sunglasses:

2 Likes

Nailed it…

2 Likes

I have the 3DConnexion driver 10.8.4 working fine on my 2019 intel MBP running Sonoma 14.4.1 with SketchUp 2024 and an ancient Space Navigator. There were some glitches at first, so I ran their uninstaller and then did a fresh install, and now it works. The only remaining issue is that the trainer window is clipped. But it works perfectly in SketchUp.

1 Like

I have 10.8.3 (I didn’t know about 10.8.4, when I ask to check it tells me I’m up to date…) the driver works well with Sonoma 14.4.1 but I’ve always had problems with 3Dconnexion products on macOS.

The most annoying thing is with my cadmouse pro wireless, the orbite tool bugs completely in bluetooth mode, so I have to plug in the cable. What a shame for a wireless mouse !

I’ve been looking for an equivalent mouse that’s really compatible with macOS. If anyone knows of one and can recommend one with the same 3-button system, I’d be interested !

You don’t happen to have the 10.8.3 installer lying around, do you?

You can get older versions of their drivers from their archive.

1 Like

Thank you! I will try dropping back a version

That archive seems very incomplete, doesn’t it?

It runs back 8 years! Were you hoping for something still older?

No, no, it just seems to be missing a bunch of in between versions, and when I search for MacOS 12, it offers v10.7.0, yet I currently have v10.8.0 installed which isn’t offered there at all.

Because I’m a packrat, I have Mac verions 10.7.4,10.8.0,10.8.1,10.8.2,10.8.3, and 10.8.4 stashed away, if anyone needs them.

1 Like