SketchUp Pro 2020 - 3d mouse doesn't work anymore

After installation of SketchupPro 2020 my 3DConnexion mouse doesn’t work anymore. I am using MacOS Catalina. With SketchupPro 2019 on the same computer everything is fine.

Do you any advise?
Thanks.

The 3d mouse uses a driver extension, I don’t believe 3d connexion have released a driver update to address the issue.
However, you can find the relevant files in the 2019 file structure and copy them to the same place in the 2020 file structure.
As I’m not a Mac user I can’t tell you where they are.
I know it works on Windows.

@TheOnlyAaron may have tried it?

This is timely because I was considering whether I should dive straight in to using SU2020 or wait a bit. Like you, I use a SM and a Mac.

You may have to rely on reloading drivers and there is a process for doing that (see SpaceMouse).

Early adoption always has its problems!

Screenshot 2020-01-29 at 12.46.06

I’ve done it on Mac, but in Mojave. Should work the same way in Catalina, I think:

Not sure if I did this bit, but it wouldn’t hurt.

Down load and run the latest installer from 3D Connexion.

Then, in Finder, use the Go menu to go to /Library/Application Support/SketchUp 2019/SketchUp/Plugins.

Note, that’s /Library/ NOT the user’s ~/Library/.

Create a new equivalent for Sketchup 2020 by copying the contents of that folder into a newly created folder /Library/Application Support/SketchUp 2020/SketchUp/Plugins. Or copy the whole folder, and rename it.

Then restart SU.

I’ve a niggling feeling I’ve forgotten one step. But I can’t remember if there is another one. @slbaumgartner might well know - I think he’s done the same thing as I did.

2 Likes

The step you’ve omitted is temporarily disabling your firewall whilst installing.

One always has to reinstall the 3DConnexion drivers after installing a new version of SketchUp. The safest way is to quit SketchUp, then uninstall (using 3DC’s uninstaller that comes as part of the driver package) and reinstall. This is no different on Catalina than on earlier versions of macOS. That’s what I would try first and see if it works, as 3DConnexion are notoriously sluggish in updating for changes to either macOS or SketchUp.

Edit: @simoncbevans has found, as he just posted, that temporarily disabling the macOS firewall while running the 3DC installer can in some cases prevent issues. The driver launches various helpers that need to connect to each other. Having the firewall on may perhaps interfere with setting this up.

I have had issues with their latest driver under SU 2019 (SketchUp going into endless orbit and zoom-out), maybe a hardware glitch but who knows. So I stayed with a previous one that didn’t have the issue. So far as I know, 3DC doesn’t have a download for older driver versions, so I did as @john_mcclenahan described. The only glitch I’ve hit in the past is that the you may not have write permission to create that folder path in /Library. The 3DC installer, like most Mac installers, runs at elevated privilege so it can do things you might not be able to do manually.

1 Like

I’ve been home sick since the release and have not seen if there is an update from 3DConnexion. Is this up ad running now? That may influence whether or not I go into the office today…

1 Like

I can’t find a plugin installer for any version, to then see if they have updated it.

I can ping you the files and location to put them.

The last version on 3DConnexion’s site is 10.6.4, released in November 2019. That’s the one I have deferred installing due to the stability issues I mentioned earlier.

if it’s working in v19 you could use Ruby Console to copy it into a v2020 folder…

%x[ditto "/Library/Application Support/SketchUp 2019/SketchUp/Plugins"  "/Library/Application Support/SketchUp 2019/SketchUp/Plugins" ]

john

Just wanted to confirm that copying the content from “/Library/Application Support/Sketchup 2019” into a new “Sketchup 2020” did the trick.

Many thanks to all.

2 Likes

I had no trouble finding that, and did install it anyway. But I don’t see any mention of SketchUp, I took it to just be the OS drivers. Does it also install the SketchUp plugin if it detects that you uses SketchUp?

Yes it does. Detection of which version(s) of SketchUp you have is why the 3DC driver must be installed after you update SketchUp.

(Re-) Installation after Sketchup update didn’t help for me. The directory had plugins all the way back until 2013 but I only have a subscription since 2018. I think it just installs everything in 3DConnexion’s installation bundle but doesn’t have an updated SU2020 plugin (yet).

Until it has we probably need to manually copy the content as described above.

The plugin itself is the same, which is why copying from an older SketchUp version works. The possible problem could be with whether the installer needs to be updated to detect 2020.

1 Like

On Mac OS Catalina, I have been through the steps of updating SU, creating a Sketchup 2020 folder in library> Application Support, copying the content of the 2019 folder to the new folder, downloading and installing another copy of the 3Dconnexion driver file.

However, the Space mouse is still not working for me in SU2020. My other SU versions work fine, as do various other modelling packages like Rhino and FormZ.

Did you restart SketchUp 2020 after copying the files (yeah, a potentially insulting question, but one never knows…)? It sounds like there is something wrong with where or how you copied them, as this has worked for others, including me. Can you show a snapshot of Finder looking at where you put them?

Yes I did restart SU (not at all insulted - it’s easy to overlook things). Here is where I put the copy of the 2019 folder

1 Like