SketchUp Pro 2020 - 3d mouse doesn't work anymore

Looks like the right folder structure. Next step would be to check the permissions (use get info) on each stage. You should have read & write permission on everything within the SketchUp folder. If that all looks ok, I’m stumped :thinking:

Permissions checked and I have read and write permissions everywhere… it’s very irritating.

1 Like

Now working! I wondered what else could be wrong and decided that possibly folder creation times might be a factor. I deleted the 2020 folder I had previously created and made a new one by duplicating and renaming the 2019 folder. Now everything is working fine - hooray!

1 Like

It’s probably the way you were holding your tongue. :crazy_face:

I just tried installing the latest 3D Connexion Windows driver (dated in December, I think), and after that (it asked me to restart my computer) the device started working normally with SketchUp 2020.

Or possibly the way I was tearing my hair!

3 Likes

Good to know. Do you use a duel monitor setup? I have a problem where the radial menu is hidden under the windows when both are open at the same time. Do you use the pop up radial
menus?

Mojave latest OS, iMac 5k 2019 with 64GB RAM and Radeon Pro Vega 48 8 GB. Just got the 2020 license today for my Sketchup Pro for Mac. Installed it. No behavior from the 3D SpaceNavigator mouse. Quit Sketchup Pro (btw, it crashed upon quit).

Installed the latest 3Dconnexion driver.

Restarted computer.

Launches SU Pro for Mac 2020, selected the woman figure, tried moving with SpaceNavigator…NOTHING.

Quit SU Pro for Mac 2020.

Launched SU Pro for Mac 2019…3D SpaceNavigator works FINE.

Quit.

Launches SU Pro for Mac 2018…3D SpaceNavigator works FINE.

Quit.

Relaunched 2020…NOTHING. Can’t believe it’s 3Dconnexion’s issue at this point.

When you install the driver it looks for software that it can add it’s bits to. 2020 is not on it’s list to look for.

Did you copy the 3DxSketchUp folder and 3DxSketchUp.rb files from:

/Library/Application Support/SketchUp 2019/SketchUp/plugins

to

/Library/Application Support/SketchUp 2020/SketchUp/plugins

?

1 Like

Which files are you referring to in the plugins directory of 2019 should be copied to the same location in the 2020 directory?

What I have in the 2019 plugins directory are the following, none of which are 3Dx… plugins.

PastedGraphic-2.png

as above
Anything that says 3dx

You are looking in your individual ~/Library folder, not the system-level /Library folder. The ~ is conventional shorthand for /Users/youruserid (where youruserid is your login name). 3DConnexion installs its stuff in /Library.

The paths I gave can be opened in two ways:

  1. In Finder, choose Go/Go to Folder… Paste in this text:

/Library/Application Support/SketchUp 2019/SketchUp/plugins

  1. Select that line of text, right-click, and choose Services/Open

Either way, you will get to the right folder.

I have the same operating system and the same problem as Stough. The plugins from 3Dconnexion must be installed differently.

what is the windows process for this?

WIndows instructions only.

Summary

Download and install the current Driver file from 3D Connexion first to be sure you are current, it may be all you need. Install the driver after installing 2020.
If that hasn’t worked after restarting your PC then…

The 3d connexion driver installer usually puts the folder and .rb for the space mouse here
C:\ProgramData\SketchUp\SketchUp 2019\SketchUp\Plugins
you should find the folder 3DxSketchup and the file 3DxSketchup.rb and copy them to the same place in your 2020 file structure. You may need to create the plugin folder as it may not have been created yet.

Or you can paste them into
C:\Users\YOUR USER NAME\AppData\Roaming\SketchUp\SketchUp 2020\SketchUp\Plugins

Either will work. It’s just that some software feels the need to put things in the program data folder, so you will have to look for them there. Twilight render is another that does this.

In short, find the folder and file called 3DxSketchup and copy them from 2019 to 2020.

My guess about why some programs put the files in ProgramData is so that it would work for all users on that PC.

1 Like

Yes Colin, that is the reason, but it’s not a very useful way of doing it, but that is a discussion for somewhere else.

i think my problem is a little different. i installed the most recent driver no prob, but the movement in SU2020 is jumpy/choppy. i’ll try your way, but i’m wondering if the space mouse just needs a driver update for 2020.