SketchUp Pro 2020 - 3d mouse doesn't work anymore

Did you install SU correctly, have you updated the graphic drivers, did it work correctly for you in a previous version, have you had other performance issues that we need to search for?
But if you think the problem you have is different then I’m happy to back out and let you sort that different one out.

no. i didn’t uninstall first. i missed that step. i uninstalled, and then reinstalled 3dx drivers. all good now.

But did you install SketchUp 2020 correctly? That is, did you right click on the downloaded installer and choose Run as administrator?

when did I mention uninstall?

This is something quite different, sorry I missed it, so the 3D Mouse drivers are working, or at least the mouse is working but not necessarily very well.
Is that true?

It’s vital to navigate to a proper Library folder, not User Library. You can’t find any 3DxSketchUp.rb files in User Library folder. What I’ve done is I’ve created a new folder SketchUp 2020 and based on chrisjknight’s experience created file structure same as in SketchUp 2019 (folders created from scratch, not copied) and after that copy/pasted 3DC’s plugins. It worked right away.

copy the sub folders :
/Library/Application Support/SketchUp 2019/SketchUp/plugins

You need to replicate this folder changing 2019 to 2020. Creating a new folder was greyed out for me so I created a new folder “SketchUp 2020” on my desktop (so the permissions didn’t block me), pasted all the copied files into it, and just dragged this new folder into the original directory directly under the “SketchUp 2019” folder. My mac then prompted me to authorize. Did that, then restarted SU - All is well with the world again

That’s a nice workaround to permission issues for non-technical users! It’s sort of equivalent to how the Mac installers automatically ask for a password before continuing because they also need to be sure to have enough permission.

Hey who are you calling non-technical! This was just easier LOL

I wondered about copying the 2019 folder to a new 2020 folder. Now the space mouse appears to be running as smooth as it does in 2019.

Just another view of the HD library where the new SketchUp folder lives.3DConnexion:SketchUp_2020|489x500

Installing a 3DxWare driver update started my Space navigator working with SketchUp 2020. The latest update (released yesterday) fixed the problem of LayOut crashing the driver.

1 Like

Yay! that worked.

Thank you for showing us that.

Same problem on my Mac. 2019 fine. Why does this happen every time SU produces an update? (2018, 2019 and now 2020). A 3D mouse is a pretty fundamental part of any 3d modelling software. It would be nice if Trimble could give more effort to ensure that these continual (and seemingly minimal) upgrades take into account the previous version’s software environment. Not much to ask.

This isn’t a SketchUp/Trimble problem or fault. It happens because 3D Connexion has to update their drivers for the new version. This happens with other software packages they support, too. Look at the 3D Connexion site and get the latest drivers.

The issue is that the previous 3DX driver version doesn’t know that there is a new version of SU and so doesn’t/can’t install their plugin to support it — which is why you have to manually copy the SU 2020 plugin folder to the /Library/Application Support/SketchUp 2020/SketchUp/Plugins location. (I should note that this is the only Extension I have that installs in the /Library/App support and not the user ~/Library/App Support location)


This one is in no way on Trimble — and though 3DX is notoriously sketchy in their Mac driver support, their current Mac version (10.6.4) seems to work fine in SU 2020… once you’ve (re-) installed the plugin to the right folder.

Edited to add: Remember to re-start your Mac after the plugin installation to load the drivers.

Which has already been explained in this thread and others, but it seems some prefer to complain rather than read.

3 Likes

You’re right Box.

But it’s easy to get frustrated when something that was working fine stops working on ‘upgrading’ to a new version. And easy while frustrated to miss a critical detail when you’re trying to sort the problem — like the correct folder location — not to mention mis-assigning the blame for the problem in the first place.

So I figured a clear repetition of the solution might help someone move out of their said frustration and back to productive work :slight_smile:

4 Likes

Greetings,

Brand new member here. Just a FYI and a big thank you.

I found this discussion after searching for a solution as to why my space mouse didn’t work for SU 2020 Pro (it was working for SU 2019 Pro).

First I tired uninstalling the space mouse driver and then reinstalling… but that didn’t work.

Next I tried manually copying the plugin files as described. I found that I did not have an existing directory for 2020 SU plugins, so I just made a copy of the 2019 plugins and renamed it to 2020. That worked!

First I was bummed, but now I’m happy!

Thanks for sharing the solution!

Pags