3D connexion space mouse and Sketchup 2019

#1

3D connexion’s Space Mouse has always been problematic, it’s usually a driver problem. Years ago I fumbled for weeks to finally learn that the driver update required wasn’t released yet.
Now it seems we have the same problem with Sketchup 2019.
Can anyone confirm that? There is no driver available for the 3D connexion Space Mouse and Sketchup 2019?
It’s a dangerous condition because every Sketchup file I’m working on is from 2018 (Pro) and they open by default to 2019. If you want to use 2019 to save them there, and they migrate, one by one as you need them, but I’m not going to save the first file in 2019, with out the Space Mouse navigator. This is a classic cluster Fuxx on the part of 3D connexion. I’m so tired of paying corporate America, and then getting this kind of of “we’ll get to that after we count our money” attitude.
Is it worth it? Just barely. Same goes for Sketchup. This last price increase was unwarranted. It might be justified if they did something to improve it other than normal maintenance.

Robert Pollock

0 Likes

#2

generally you always need to instal any 3D CON driver after you install an upgrade SU…

try it…

john

1 Like

#3

I’m using a space navigator with SketchUp 2019 on my Mac. You have to install the 3Dconnexion driver after installing SketchUp, but then it works.

1 Like

#4

Works fine on Win 10 for me.

0 Likes

#5

I ran the 3dconnexion installer after upgrading to ‘19 and all is well for me!

0 Likes

#6

I didn’t have to reload anything after installing SU2019 on my Mac. SM just worked.

0 Likes

#7

That’s surprising as the extension installs separately for each version - or at least it always has before…

0 Likes

#8

I installed 2019 Classic today and I carefully followed what, based on conversations in this topic and others on the forum, is the best practice as follows:

  1. Downloaded the new installer package
  2. Navigated to it in my “Downloads–>Installer Packages” folder (were I directed it be store in step #2016
  3. Right clicked on the .exe and chose “Run as Administrator”

Once it was done installing, I tried the SpaceMouse Pro (Wireless), does NOT work in 2019, but working fine in 2018. I did this test because I knew I wanted to post here, so I don['t consider this a failure - just a point of information.

  1. Next, I navigated to the 3dConnexion, found the most recent driver, downloaded and installed it - again using “Run as Administrator”

Result: My SpaceMouse Pro (wireless) is running well in both 2018 and 2019 (also 2017 - which I still have installed).

0 Likes

#9

Thank you sjdorst:

Robert Pollock

0 Likes

#10

Slbaumgartner:

Three people responded and I have a modified routine that will probably solve the problem. Simply re-installing the SM driver after SKUP 2019 is installed apparently will make the SM work in both 2019 and 2018.

Thank you for your interest.

Robert Pollock

0 Likes

#11

Simoncbevans:

Three people responded and I have a modified routine that will probably solve the problem. Simply re-installing the SM driver after SKUP 2019 is installed apparently will make the SM work in both 2019 and 2018.

Thank you for your interest.

Robert Pollock

0 Likes

#12

So did mine, until it stopped working & caused a bit of havoc ! I installed the latest driver which was available on the 10th.

0 Likes

#13

Please update your profile. It says you are still using SketchUp 2018 which I presume is not correct as this topic is about 2019. Also, it says you are using High Sierra 10.14.2, but 10.14.2 is Mojave.

(I would have sent this as a PM, as it is off-topic, but you have PM’s disabled in your forum preferences)

0 Likes

#14

I did make an attempt to move over to 2019, since I paid for the update, but there are some problems with extensions and the warehouse/extension manager. So I’m using both, 2008 for work & 2019 for messing about. Thanks for mentioning my profile, I’ll fix it.

0 Likes

#15

I think you have me confused with someone else, I’m a Windows person, those names ‘High Sierra’ and Mojave are Apple OS’s aren’t they?

0 Likes

#16

I was replying to @westsalish the immediately prior post. I should have made that clear. Sorry!

0 Likes

#17

Last night I downloaded the newest 3D connexion driver and now the SM is working, but terribly. It’s jerky and too slow to be useful. I’m playing with that frustrating interface now, trying to coax some responsiveness from it. If they weren’t so good when they do work, I’d get rid of it fast. Either it’s working or you can’t seem to fix it always.

0 Likes

#18

version 10.6.1 was released on 2019-Jan-10. Works better than ever, so far :crossed_fingers::crossed_fingers: in both 2018 & 2019. If you don’t delete the previous
version, in my experience, you’ll have those problems that I know about all too well.

0 Likes

#19

so basically update the driver lol

0 Likes

#20

It may not be that simple. When I installed SU2019, my SM worked fine without new drivers. Then the other day, it suddenly stopped responding. So I went through the rigmarole of reinstalling the driver, which is a FAFF. Bingo! All seemed well, until today when I see the SM has stopped responding again. I guess I will have to go through the Evans Method of reinstalling yet again but it’s going to be a pain if that keeps happening.

My SM is wired so it’s nothing to do with wireless operation.

0 Likes