Space Mouse not working after 2022 update

Space Mouse not working after 2022 update.
Using windows 10
Any suggestions welcome

It’s a 3D Connexion problem - drivers not yet updated I believe.

Thanks Guido.
Back to the standard Mouse.

Have you been reinstalled the Space Mouse driver after SU 2022 installation?
If not, try it! :wink:

Hi dezmo
Yes and still did not work.
Reading through old posts it look as if the same thing happened in 2021 when SU was upgraded.
Just have to wait and see what happens.
Thanks for your reply

Strange! Mine is working
(3DxWare64_v10-8-4_r3407)

Are you sure you installed properly?
Do you see the plugin installed in your Extension manager?

Maybe you can try to uninstall 3DX driver, then reboot, then reinstall.

1 Like

You shouldn’t have to wait, it does work with 22 and win 10.
You must install the drivers After installing 2022. Reboot your PC and unplug the spacemouse then plug it in again. If all that doesn’t work it is possible to copy the files from 2021 to 2022.

i have the same issue

Have you tried the process @Box described?

Hello slbaumgartner. Can you elaborate on @BOX.
I have tried everything.
My space mouse works well when testing within 3Dconnexion demo programme.
When in spetchup the Space Mouse zooms in and out but will not rotate or do anything else.
Tried every setting available in 3Dconnexion and nothing changes when in sketchup.
The Space Mouse works well but not in sketchup.
Any suggestions welcome
Thanks

Sorry… YES I have tried the suggestion from BOX

Did you download and install the latest driver version from 3D Connexion? There was an update in late December.

1 Like

Follow the cleanup for windows

Please update your forum profile. It says you are running 2019 but the topic title and first post are about 2022. The answer could be different for these two versions!

That behavior indicates that the extension to integrate with SketchUp has not been installed or enabled. If you open the SketchUp Extension Manager, do you see an extension named “3DxSketchUp” and if so, is it enabled? If not, the driver installer failed to add the extension for SketchUp 2022 (it has to be put into a distinct folder for each SU version). The installer is supposed to search for all installed versions and add to each, but sometimes that fails on a new release of SketchUp for reasons I don’t know.

When all else fails, one can copy the 3Dconnexion extension files (after installing the newest driver) from the install location for an earlier SU version to the location for SU 2022. I’m a Mac user, so I can’t tell you where that is, but hopefully a Windows guru will provide the right info.

Hello slbaumgartner.
Thank you for the info and that sounds plausible.
Yes all ok within extension manger.
I will be patient and see if there is any Window guru’s about.
Many thanks

Hello Anssi.
Yes downloaded new drivers for 3Dconnexion.
Removed and then downloaded again.
Also removed SU 22 and then reinstalled again.
Tried it all in many different ways but still only “in & Out” working whilst in SU
Thanks

Note: you MUST run the 3Dconnexion installer AFTER installing a version of SketchUp, not before! You must also quit and relaunch SketchUp after running the 3Dc installer.

First thing, Go to the downloaded sketchup installer .exe (if you don’t have it download it again) select it, right click on it and choose Run as administrator. Follow the prompts and choose Repair when given the option. Once done, reboot your PC and check if spacemouse is working in SU.

If not,
Go to C:\ProgramData\SketchUp\SketchUp 2022\SketchUp\Plugins
select the folder and file both named 3DxSketchup and cut to clipboard,
Go to C:\Users\Your User Name\AppData\Roaming\SketchUp\SketchUp 2022\SketchUp\Plugins
and paste the folder and file in there.
Open Sketchup and check spacemouse.

As a side note, when filling in your profile Windows isn’t enough, I have guessed you are on Win 10 but these instructions would be different for win 7 or win 11.

1 Like

Windows 10

You already had it in your profile.