SpaceMouse Pro and SketchUp 2022 release

Upgrade to SketchUp Pro 2022. However, it seems that SpaceMouse Pro is not working with the new SketchUp release. Any suggestions, please. Thanks in advance.

See this thread:

As said before, you have to reinstall the SpaceMouse driver. Download the latest version that was released in late December.

My SpaceMouse Enterprise Kit #2 isn’t working with SketchUp Pro 2022. I’ve installed the latest driver. It works in the 3Dconnexion Demo but not in SketchUp. I can open the Menu while in SketchUp and see that I can set my buttons but it doesn’t move my model around.

Let me know if you guys have any ideas. I’m at a full stop.

Here is my Tech Support Ticket.

Driver issues since install of SketchUp Pro 2022

I have been using my 3Dconnexion 3DX-700028 SpaceNavigator 3D Mouse since 2013 without issue and LOVE it. I have been using it with SketchUp Pro 2019 and it worked great until I had to install SketchUp Pro 2022 for a new project. It wouldn’t work and said I needed to install the new drivers. I was on driver 3DxWare64_v10-6-0_r2972. So I had to uninstall that driver and install your latest 3DxWare64_v10-8-4_r3407. As soon as I did that I got a notice that my old 3DX-700028 SpaceNavigator was not supported anymore. So I uninstalled the new 10.8 drivers and reinstalled the 10.6 drivers. Went back to using my old 3DX-700028 SpaceNavigator with SketchUp Pro 2019 but now the driver is crashing and erasing the custom radial button settings that I use in SketchUp.

I ordered your $400 3DConnexion SpaceMouse Enterprise Kit 2 overnight on Amazon to replace my old 3DX-700028 SpaceNavigator but now it doesn’t want to work either. It doesn’t work in SketchUp Pro 2019 or in SketchUp Pro 2022. I have tried using both the 10.6 and the 10.8 drivers. I’m in the middle of a couple of projects and I am down two full workdays dealing with this. I really need to get back up and running asap, Please call me to get me back to work. (623) 451-3701

Please don’t double post, the other thread you have now created will just cause confusion, and is against forum guidelines.

Have you rebooted your PC?
Have you Unplugged and plugged your device back in?
Have you checked that the Extension is showing the the Extension Manager and is Enabled?
Have you tried to manually move extension files around?

Have you rebooted your PC? Yes
Have you Unplugged and plugged your device back in? Yes
Have you checked that the Extension is showing the the Extension Manager and is Enabled? Yes
Have you tried to manually move extension files around? No

I gave this suggestion in another thread about this.


Completed both but it didn’t work. I had high hopes. Thanks for your help. Bottons still work but nav puck doesn’t move anything.

  1. choose Run as administrator. Follow the prompts and choose Repair when given the option. Once done, reboot your PC and check if spacemouse is working in SU.

  2. Go to C:\ProgramData\SketchUp\SketchUp 2022\SketchUp\Plugins
    select the folder and file both named 3DxSketchup and cut to clipboard,
    Go to C:\Users\YourUserName\AppData\Roaming\SketchUp\SketchUp 2022\SketchUp\Plugins and paste the folder and file in there.
    Open Sketchup and check spacemouse.

That’s a shame.
There must be something different on some systems.
Perhaps some antivirus or firewall is blocking it from fully installing.
Perhaps try deleting those two files you moved, then reinstall the 3dconnexion driver with your antivirus an/or firewall off temporarily.

I will give that a shot next. Thanks.

3D Connexion has a phone number on its website. Give them a call during the day. 3DConnexion Support. ( North America

Mon – Fri: 9:00 am to 5:00 pm ET

1 888 847 4670])

Thanks. I will be checking in with them tomorrow morning.

Here is another possible option.


How many times? I basically reinstall the drivers every time I want to use the Spacemouse. Which on average is twice a day.

Once after every major upgrade should be enough…