Support in 2022 for 3DConnexion enterprise mouse

I just installed SketchUp pro 2022. Now my 3D mouse does not work. When can we expect to see support for the 3DConnexion enterprise mouse?

This would be in 3D Connexion’s court. Have you gotten their latest drivers and installed them after installing SketchUp 2022?

On a side note, make sure that you installed SketchUp 2022 correctly by right clicking on the downloaded installer and selecting Run as administrator from the context menu.


I have had something strange happening with mine as well, only after installing 2022.
My 3DConnexion Spacemouse works on my works laptop, but not my home computer.
It worked on my home computer before I installed 2022. (Yes 2022 was installed using Run as administrator)
It works on 3Dconnexion Home on my home computer and also SketchUp 2022 recognises the pushing of the buttons on the 3d mouse but I can’t pan, zoom or anything to do with the controller cap.
I looked into the settings to see if the install has deactivated the movements but they are still ticked.
I tried resetting the controls but that didn’t fix it.
I’m still looking into this.

Did you install the 3DConnexion drivers after installing SketchUp 2022?

Did you download and install the latest version of the drivers from 3DConnexion after installing SketchUp 2022? You have to do that - the driver installer detects the presence of SketchUp and installs the extension that is needed for the Spacemoude to work.

No, I thought I didn’t need to as I presumed that it would be the same from 2021. I will try that tomorrow.

The 3D Connexion drivers will look for SketchUp 2022 during installation and install what they need to support it. Make sure you get the most recent copy of those drivers from their website.

I believe it has to be done this way because each version of SketchUp installs as a separate application and uses distinct folders to hold its various configuration, extension, files, etc.

So I uninstalled the driver for 3dconnexion and downloaded the latest version.
Everything is up and running now.
Many thanks @Anssi and @DaveR for your help. It’s greatly appreciated.
I hope that this also worked for the OP.

1 Like