Space Mouse not working after 2022 update

Hello BOX
Tried all that and unfortunately it did not work.
Still only getting back and forward when using space mouse in SU

Open to any suggestion!
Many thanks


2022 SU plug in

All sorted… Ya hoooo
Renamed 3Dconnexion files to 3Dconnexion.bak
Deleted from SU.
Reboot and now all working in SU.
Time to catch up on backlog of drawings.
Going to be a long and late few days.
Thanks to everyone for the input, help and advise.

2 Likes

Interesting, could you expand on this for others in the same situation, which files exactly did you rename and what did you delete from SU?

I have the same problem on my MAC with 2022 with Monterey. It crashes SU when drivers loaded and wireless Space Mouse tried. SU2022 wel will run if drivers deleted. In touch with 3Dconexion with no answer. Able to still use SU2021 on my windows pc and space mouse. Not preferred option.

I have this problem with my laptop. I’ll study the above and report back.

Have you installed the 10.7.0 driver from 3DConnexion? Older ones might not work with Monterey. Is your Mac Intel or Apple M1?

I have encountered a bug in their extension that causes SketchUp to crash the first time it is launched after a restart or cold boot of my Mac. Normally if I keep trying, all will be well after one or sometimes several relaunches of SketchUp. Like you, no reply from either 3DC or the SketchUp team.

Everything is up to date. Monterey SU2020. It’s an Intel Mac 2017.

Might try the extra steps you suggest. History says the supplier is slow in updating their drivers.

What, you mean 18 months to update for Big Sur after its release isn’t fast enough? :slight_smile:

Yeh!!! :weary:

I have had a pretty awful afternoon but Box (above) reminded of what I had to do on previous versions of MacOS. I removed all trace of the 3dConnexion driver, unplugged the mouse and did a re-install and it all works fine- I think the problem was installing the drivers before installing sketchup. I’m running Monterey on Intel with SU22. All seems to be fine now. Fingers crossed

I have tried that over and over and if the mouse is connected or not, once the software is loaded SU will crash. Thought it was SU and although I run an Intel Mac (2017) it works if no 3DCX is running despite SU say the Intel Graphics hardware in my Mac is not compatible with SU. Suspect its the old chestnut that 3DX are slow to bring working drivers to the market… despite the Space Mouse being wonderful hardware, the software is just ■■■■.

Same, I get a crash, but then open again and it is fine. SKP is very jittery when orbiting using the SpaceMouse Enterprise, but orbits fine with the CadMouse.

I have seen a lot of jumpiness with the Enterprise, too. No crashes, but anytime I try to do anything whole orbiting, it jumps. I had heard there was a newer version of the driver than what I have loaded. Might try that after the live stream.

Hmmm, couldn’t find an update.
Super smooth in the little training app they have in settings. Jumpy in SKP.

Let me know if you find a fix.

I notice jumpiness if I make any movement with the regular mouse while also orbiting with the space mouse. It seems like they compete for SketchUp’s attention. For me the workaround is to make sure not to move the regular mouse while using the space mouse.

1 Like

Yes, but this wasn’t the problem - I also do that…

Seems to have cleared up after a couple of re-boots.

Corded or cordless? I gave up on Bluetooth mouses as they seemed to compete with other Bluetooth devices, and I use my Logitech mouse through its own receiver.

The space mouse is corded. I’ve used both Bluetooth and proprietary wireless mice.

Is it possible the Bluetooth is suffering from outside interference? I have my receivers separated from each other and away from the PC. Prior to that, I had issues with my MX2 and keyboard. After I moved the receiver for it things settled down. When I added my Wireless Spacemouse, I placed the receiver away from all metal and other wiring.