3D connexion space mouse and Sketchup 2019

On a Mac, absolutely no issues upgrading to Sketchup Pro 2019


I emailed 3DX about it on 19 Feb. They responded as follows:

Dear customer, you sent us this message.

Subject: Spacemouse Pro & Mojave
Contact: Administration
_Message: _
I recently upgraded to OSX Mojave. Initially, my SM Pro worked fine. Then, without anything being knowingly changed, it stopped responding. So I reinstalled the driver. That fixed it. But today, the mouse is dead again. Is there a known issue with Mojave that leads to the system no longer recognising the mouse? It wouldn’t be so bad if it weren’t such a trial to reload drivers. It only works for me if I disable the firewall during installation. Then I have to remember to close it again afterwards.

We are processing your request and will contact you as soon as possible to find a solution.

So far, nothing.

I may have found a workaround. You won’ be surprised at it. If I turn the Mac off and then back on again, the connection is regained.

I imagine what is happening here is that Mojave is having to support the SpaceMouse rather like you holding your arm out straight with a weight in your hand. Eventually, you have to drop your arm and regenerate before starting again. Something like that anyway.

Based on their track record, don’t hold your breath :sleeping:

When I first got the Space mouse about five years ago, it had to be fiddled with, and then one day it just worked. I hate it when the computer is fixed but you don’t know how or why. Now it’s working fine again in 2019, better even than it did in Sketchup 2018. I haven’t worked in Layout yet, I’m told 2019 works faster than the previous versions. For now, Sketchup is the program, and Space mouse is the navigator but if something else that’s less expensive and less problematic comes along……

Same problem today. On windows 7 64. Have you solve? How?

What I did:
I opened Windows Control panel>3Dconnexion Properties>More>About and pressed the “Check for Update” button. I closed the control panel, downloaded and installed the driver update and after that my Space Navigator works OK in SketchUp Pro 2019. Same old Win7 64 OS as you.

windows 10 64, sketchup pro 2018 - tried all of the above to no avail. Simply cannot get spacemouse to work without hanging and pausing every 3 seconds or so. so infuriating.

I Installed Fresh copy of SU 2019 on new Macbook pro, and installed SM with latest OS driver available on site, but am unable to work, SM is controlling my mouse pointer instead. also I can’t see SM in preferences on SU2019. I tried uninstalling both SU and SM. but still no luck. anyone know how to fix it.

I suppose there are 2 questions here.

  1. does it actually works on your system? I have similar, works fine with last drivers.
  2. jittery movement of your model? How big is the model? This is a known behaviour for large models, as when you orbit with mouse - SU stops rendering the model until you finish movement. With Space mouse it renders the model continuously. So - just optimise the model, e.g. hide layers/objects that you don’t need at the moment.

It’s not jittery movement, it’s that the movement hangs – like it loses the connection to the mouse for a moment, then picks back up. Instead of a smooth flow as you are moving around, it pauses every few seconds, making precise adjustments
nearly impossible and frustrating.

So – yes , it is connected and working

No – it’s not jittery, but pauses at regular intervals. I do not have this problem with my Microsoft Surface Pro laptop, but this high power gaming machine does. Very frustrating.

I have updated drivers every time they come out. Must be some issue with this machine, but I cant figure out how to resolve it.


I had a possibly similar issue on my iMac in SU 2019.

After hours of wasted time fiddling about, I found out from 3DConnexion support that with the wireless receiver plugged in to a USB Hub, it doesn’t work well (or at all in some cases).

Moving the receiver to a USB socket on the computer fixed the issue and it now works fine.

I assume that you mean that you can’t find 3Dconnexion in Apple Menu > System Preferences ? That’s where you configure “Google Sketchup”, not in the SketchUp preferences.

wireless or cable? Try using main USB port (on computer/laptop, not hub)
do you have the same issue on a very small model? (e.g. just a cube)

1 Like

Thanks for the suggestions. Unfortunately, I’ve tried those ideas already.

I do connect it directly to the usb3 port, not through a hub.

Problem occurs even when there is even no model- just an empty canvas, so it’s not a model size issue.

Do you have access to another PC to test the mouse on??

Did you install the latest 3dconnexion driver after installing 2019?
And did you install sketchup using the Right Click, Run as admin method on the install .exe?

Yes- I have a surface pro laptop which is gutless compared to my gaming laptop, but the mouse moves smoothly, also my tower pc works fine as well- no hesitation. Something to do with the drivers/hardware of my laptop, but it makes
it pretty much useless as a result.

no, am able to find 3Dconnexion in apple system preferences, have set there to sketchup but still its controlling mouse pointer not SU.