3D Connexion

Upgraded to SketchUp 2020 and now trying to have my 3Dconnexion wireless mouse reconnect with the application. Downloaded 3D Connexions’ latest driver but still no luck…I really do
not know if this is a SU or 3D Connexion problem?

There are other long discussions about this elsewhere in the forum. Some people are having performance issues, but for just getting it going in 2020, goo into this folder:

/Library/Application Support/SketchUp 2019/SketchUp/plugins

copy the two 3DX items, then go into here:

/Library/Application Support/SketchUp 2020/SketchUp/

If there is no plugins folder, make one. If it’s there, go into it and paste the two items you copied.

Note that the path starts with /Library and not ~/Library. Use the Finder Go menu, Go to Folder… to get to those two places.

1 Like

THANK YOU- This worked for me!

I’ve been trawling for work-arounds on how to get my SpaceMouse working with SU2020 Pro. I’ve followed all the steps, added the plugins folder, and uninstalled and reinstalled ad nauseam.
My 3d mouse zooms and moves the cursor in SU, but I really need the rotate and pan functions. Any thoughts on why this isn’t working? I’ve got a support request in with 3Dconnexion, but they’re in Europe and I’m in Australia, so it’s 12 hours between Q and A.
Any advice appreciated!

@simoncbevans had issues with his Mac. Somewhere in the forum there is a post by him about how he installed it. I have searched but have not found it. I did find it had to do with the firewall on a MAC. GL. Maybe Simon will chime in.

@simoncbevans found on Mac that if he temporarily turned off the Mac firewall while installing the 3D connexion driver that he did not have further issues. I’m on my phone now, but I think it’s in the system preferences security and privacy panel of macOS.

Firs thing to say is that my problem was to do with memory runaway, not on getting the SM to work in the first place. However, in case it is still useful, the relevant thread everyone was looking for is here: SpaceMouse

It is actually very simple. You just turn off the firewall in System Preferences before you install the driver. Then you can turn it back on again.

I have seen it suggested recently, I think by @slbaumgartner, that it is no longer necessary to go through this palaver, so it might not have any effect on @mandpbetts’s issue.

Thanks all - I’ll have another go…

Man… Same issue going to 3DX 10.6.5 here with the Space Navigator! Followed and checked all of the the suggested maneuvers here in the forums.

After Uninstalling/Reinstalling, no firewall, checking the library folder everything is in place. As a matter of fact, all versions of SU had the plugin folder structure copied correctly.

I can only see the Cad Mouse, not the SN.

Any help is greatly appreciated… 3DX must have taken a hit here… This is so frustrating.

(I just started to go back to the Mac platform because you can import a pdf into Layout. Otherwise I would not be here.)

I had same issue this worked for me on ,Mac attaching email I had from 3dx

Almost feel like I’m talking to myself. Neither of us can be @TheOnlyColin, like there is @TheOnlyAaron.

Good idea about the input monitoring, I hadn’t even heard of that. But in my case the 3DConnexion entry was already checked.

1 Like

Same here. I’m back to using a normal mouse at the moment, and pretending it’s fine.
I’ve exhausted all the advice from 3DC, and now they’ve gone quiet…