3D Connexion Mouse won't work with SU Make 2016

Hi All

I’m having a problem with my 3d Connexion Wireless Mouse and the new SU Make 2016.

The mouse will work with SketchUp as it has with 2015, 14 etc, but I can’t adjust/personalise any of the settings, so everything feels back-to-front and upside down. It’s like driving a car where the wheel controls the gas and brakes and the pedals turn left and right!

I’ve downloaded the latest drivers (I think) and I’ve made sure the extension box is ticked in SU preferences. I’ve tried going back to SU 2015, but the problem is there now too. It’s all happened since I upgraded to 2016. I’ve uninstalled SU and 3dConnexion and reinstalled them, but nothing has worked.

Does anyone have any ideas? I was thinking about upgrading to Pro but if there’s a problem with the Mouse it might not be worth. I love that mouse now.

Any help, greatly appreciated.

Andy

read the other 3d connexion thread…

I have. I’ve read them all but no dice.

I’ve also tested the mouse with Safari and Google Earth and changing settings in those programs works fine, just not in SU.

What I don’t get is how it has affected SU Make 2015, which was working fine.

I had a rough time with updating from 2015 to 2016, as far as the 3D mouse software was concerned. I had to uninstall 2016, then uninstall 3DConnexion software (and manually delete the files left behind), then reinstall 2016, THEN reinstall the newest 3DConnexion software.

Once I did this, I had to remap my buttons/axis, but it worked like I would expect.

Thanks for taking the trouble to reply, TheOnlyAaron.

Annoyingly, and I really hoped your advice would work, but it hasn’t changed anything. So frustrating. I didn’t realise how much I’ve come to rely on the 3D Mouse.

Can I ask if you’re using SU 2016 Pro or SU 2016 Make? I’m loathe to buy Pro if the mouse still won’t work.

Just wondering of anyone else has experienced this problem??

Thanks again for replying.

I am using Pro (it comes with the job :wink:). I would reach out to 3DConnexion support, if I were you. They have great support and will do their best to get you up and running.

Thanks Aaron. I’ve tried 3dConnexion now.

Got one reply off them, which made sense but I couldn’t make work. Their advice was to “go to properties–> advanced settings and you can find reverse option here to reverse every axis.” which seems like what my problem is (everything feels in reverse) but my properties doesn’t have an advance setting section so no reverse button. I’m waiting for another answer from them. Will post any solutions or updates.

Are you looking in the settings for the Space Mouse?

Hi catamountain

I’m in properties. Is there another place for settings? ‘Preferences’ is greyed out in Space Mouse Home, in the menu bar.

I’m in ‘system preferences’

Looks like you have a Mac.

The way I have things set in Windows, I can open the 3dconnexion properties through the task bar. It seems what I can open through the taskbar is different than the dialog open through the mouse itself. As seen below, whatever program is in focus, the mouse property is adjusted for that program.

Andy did you try the Sketchup Drop Down in Sys Prefs

if you set the Popup Menu in Radial Menu’s you can adjust some things inside SU…


john

Hi John

Thanks for the reply. I’ve been playing with the SU drop down menu in system preferences, trying to put in my own settings. I also just tried putting in your Pop Up menu suggestion. I really hoped that would work. It didn’t, but what it’s made me realise is that SU isn’t seeing any of the settings I’m putting in for it using system preferences. Your pop up menu idea came up for Safari and Google Earth, but SU just stays at it’s own default settings. Nothing changes. It seems to not respond to system prefs anymore. It has in the past as I’ve played with my settings a lot. Curiouser and curiouser.

And Catamountain, it looks like the options in Windows are a lot more user friendly than the mac ones. I want those!!

do you have more than one version of SU?

I have 5 versions so I’m suggesting not to…

if you do, it may be worth disabling the plugin in the other versions by adding a bang

!

to /Library/Application Support/SketchUp 2015/SketchUp/Plugins/3DxSketchUp.rb! for example…
and then do a ‘Restart’ to see if now sees v16 correctly…

IMHO the plugin is flawed on a mac, but can be made useable, if you work out which way to hold your tongue…

john

Hi John

I don’t have any other versions of SU (which feels part of the problem - I foolishly deleted 2015 before opening 2016 - wish I could go back now but I can’t find a copy of SU Make 2015 online)

I went to the folder you suggested there aren’t any 3dConnexion plugins at all, for any version of SU, not even 2016. Does that seem weird? Should there be? I’ve installed the plugin from 3d Mouse Properties, but there’s nothing in the SU folder you pointed me at. It looks like this:

Could the problem be that I’m missing the plugin?

that’s you User folder, where things ‘should’ be, but 3DConnexion makes it’s own folder at the

HD/Library/Application Support/SketchUp 2015/SketchUp/Plugins/3DxSketchUp.rb

that’s where you need to look…

Thanks for the tip again, John.

I went there as well but still no joy. I’ve now downloaded a trial version of SU 2016 Pro, but still having exactly the same problem. This is really infuriating. I don’t want to upgrade to Pro if the 3D Mouse won’t work. 3DConnexion haven’t been able to offer any support but I can’t believe I’m the only person having this problem now. The mouse works fine with all my other apps, just not SU.

your not the only, I only turned it all back on to answer your queries…
the next session of SU I noticed memory spiralling out of control…

I shut it down at approx. 25GB as I only have 4GB of ram…

It then did the same thing every time I opened SU…

I could only fix it by uninstalling 3Dconnexion and a System restart…

It’s a pain in the butt, but I’d rather use the mouse and shortcut keys then revert to v15…

the mac driver is faulty, and the extension cannot be turned off from SU, like it should…

john

It’s really annoying. Didn’t realise I was so hooked on using the 3D mouse, but it’s really put me off using SU now. Also, I emailed SU help about it but got fobbed off.

You’re saying it’s a problem with SU rather than 3dConnexion though? Just wondering who to chase about it.

NO, not SU the app per say, but it’s definitely 3dConnexion plugin for SU causing me grief…