3D Connexion Mouse "Space Explorer" does not work in Sketchup 2017


#1

I am using the 3D Connexion Mouse “Space Explorer” for some years now. The 3D Connexion company marks this 3D mouse as not supported anymore (hence I cant approach them to solve this problem). Moreover, it works fantastic. It works fine with my CAD software (IronCad and Space Claim) and the Adobe PDF. In Sketchup 2017 Pro it does not work.
I re-downloaded the latest driver for the above mouse.
Looking at this forum posts, it seems this 3D mouse issue keeps coming in every release of Sketchup.

Any help is appreciated.
Thanks
AR


#2

It seems users post here first rather than checking for driver updates from 3DConnexion as they should do. Unfortunately if 3DConnexion isn’t supporting your Space Explorer anymore, there’s not much you can do short of getting a newer supported model.


#3

Dave,
Thanks for responding.
As I said in my post, I did check 3D connexions and did get the latest driver for that model of the mouse for win10- 64 bit.
Do you see any reason why (i) the same mouse would work beautifully in other apps but not in Sketchup 2017 (ii) every new release of Sketchup has had the same issue as I see from this forum.
If there is anything I can do in Sketchup, please let me know. Earlier solutions in this forum for the same problem (for earlier versions of Sketchup) suggest that I should set up in Sketchupmy preferences regarding 3D mouse. But I dont see any such provision in the Sketchup 2017.
Any help is appreciated.
Thanks
AR


#4

The 3D mouse is a 3rd-party application, and SU provides a Ruby API for 3rd-party development. And with each version upgrade, the developer environment also is updated. So a number of plugins/extensions may not work in the latest version of SU unless the extension is also updated to meet the new requirements.

The old driver you installed was not developed for the latest version of SU. So its support files are not even installed for the latest version of SU. Even if you retrieve them from an older version of SU (if you have older versions of SU installed) and place those files where they need to go for SU17, the 3D mouse still would not work.

If you tried contacting 3DConnexion, like I once did when I still wanted to use my unsupported Space Pilot, they probably would tell you to try the latest driver which supports SU17. While they dropped supporting and testing their old products, the latest driver may still work - at least until they don’t anymore. This may get you a few more years of use of the discontinued space mouse.


#5

@catamountain, your explanation enlightens me a lot. I will try to be in touch with 3Dconnexion team and see if they can offer the ruby plugin updated for SU17.
Alternatively, I myself would like to spend some time to see if I can update the plugin myself. (I am C/C++/perl/java/python/expect develeoper).
If you can throw me the helpful links for my goal, I would appreciate. (I am new to Sketchup). I will also search for ruby development tool and latest plugin for 3D mouse.
Thanks for being a patient teacher.
nb: I am looking at http://developer.sketchup.com/en/content/welcome . Will go from here.


#6

The issue is resolved. Thanks to all for the help.

I followed the advice as per 3DConnexions techincal staff which I give below:
==== pasted below=======
Our Space Explorer is considered a discontinued unit, but it should work in Sketch Up.
What I can recommend is updating your driver to our latest build http://www.3dconnexion.com/service/drivers.html
While not tested with the Space Explorer I did use the 10.4.8 to succesfully use my Space Explorer in Sketch Up 2017.
Once you have updated the driver and restarted the machine please load Sketch Up.
If you are unable to move the model please go to Windows > Extension Manager and make sure 3DxSketch is enabled It will say out of date but it will still function in 2017
====== paste ends =============
My additional comment: The restart of pc after installation of the driver is a must. (The install program does not say so). This is what resulted in my failed attempts.
Also, the 3DConnexion website recommends driver version 3DxWare64_v10-4-3_r2328 for Space Explorer mouse USB, whereas the latest version 10.4.8 works in both SketchUp and IronCAD the 2 CADs I tried. FYI.