Sketchup 2017 with 3D Mouse Connexion


#1

Hello everybody,

I’ve read quite a lot posts on this topic but unfortunately I am still not able to make it work: Sketchup 2017 with 3D Mouse Connexion

I installed SketchUp2017 (17.1.174 64bit)
Updated Connexion Driver (3DxWare64_v10-4-8_r248)
Restarted the system several times
Reinstalled SketchUp 2017
Installed SketchUp 2016
Updated Connexion Driver again.

I don’t know what I’m doing wrong…
Do you guys have any idea what I can try to make it work…!?

Thanks a lot!


#2

Have you reached out to 3DConnexion? They are very responsive and offer very good support.


#3

Hi Aaron,
thanks for your quick response!
Haven’t tried yet…
Ich will give it a try!

Cheers


#4

Have you tried uninstalling the 3DConnexion driver > reboot > then reinstall the latest driver?


#5

Hallo catamountain,

Yes I did. Ich reinstalled the connexion driver twice. The computer was
rebooted after deinstallation and after Installation…

Cheers…


#6

Have you checked that it is Enabled in the Extension Manager?


#7

Which Extension in the Extension Manager needs to be enabled. I cannot find
an extension called 3D mouse…
I already looked it up in the Warehouse but did not find an extension. Is
this extension preinstalled?

Thanks a lot!
Dominic


#8

I posted a screen grab of the extension above,
Extension Name, 3DxSketchup/ Author, 3Dconnexion.
This will appear in the Extension Manager within Sketchup if you have successfully installed the most recent Driver from 3DConnexion.
Until that is showing it won’t function.


#9

Be sure to ‘Install Plugins’ any time you update the 3dConnexion drivers’


#10

Hey guys,

probably I do not see the wood for the trees…
@Box: Extension 3DxSketchup is not installed
@bmike: If I want to have this extension installed I need to install a Plugin within the connexion software/driver?
Your screenshot show’s something I do not have available… :frowning:
The only “setup tool” I do have available is “3Dconnexion Home”, there is no Plugin function available…

Somehow I get the feeling that I’m doing something completely wrong… :frowning:

Cheers


#11


#12

Problem solved…
I just decided to reinstall again the driver and there was ist…
After running the driver.exe file I get to choose:

  • make changes to the software
  • repair the software
  • uninstall the software

I alwas reinstalled it. During the installation process I somehow did not find the checkmark “SketchUp”.
By choosing “make changes to the software” I was able to select SketchUp, click ok and it was done…

Thanks a lot for your Support!!! Great!

Cheers and best greetings from Germany,
Lufti


#13

Make sure you check that 3Dconnexion is enabled in Extentions Manager.
It took me forever to find this post which points this out.