SketchUp 2016 & 3DConnexion 3D mouse

2016

#1

Has anyone try there 3D mouse and SketchUp 2016?


Hardware Purchasing Advice For SketchUp & LayOut [wiki]
#2

Make sure you install a fresh copy of the plug-in/driver for it.


#3

I can confirm it works, but as Dave mentions you need to reinstall the driver.


#4

Thanks. I will download now :smile:


#5

Space Navigator works fine without reinstalling. Maybe it might be a problem if you have an older version of 3dxware


#6

I download the new SketchUp and all is working. I downloaded the new driver about three weeks ago :smile:


#7

Had issues, read the Forum, installed the driver, restarted the mac and works :smile:
Thanks a Lot.

Footnote: SketchUp 2016 still only supports 5 Axes of the SpaceMouse :frowning:
(corrected, see below)


#8

In the space mouse settings untick Lock Horizon.


#9

That’s just great, thanks a Lot.
I did actually need to google what you ment.
Couldn’t find the settings in SketchUp or the 3D-Connexion in my System Preferences (OSX 10.11.1)
Took me a while to figure out, that there is a “hidden” Menu that you can only access by pressing the Button on the SpacePilot Pro. One might say it’s labled “Menu” for a reason but I never pressed that one so far :smile:


#10

My 3D mouse worked perfectly in SKP 2015 but cannot be programmed in 2016. There is a 3DX plugin comes supplied with 2016 in the system library > Application Support > Sketchup 2016 > Sketchup > Plugins and the 3D mouse seems to work according to whatever settings are installed in this. But I am unable to program any settings in the 3DConnexion Preference Panel. I can change the settings but the mouse does not follow any of the changed settings. I notice also that when I try to program the buttons that “Application Command” in the drop down box, which allows you to access Sketchup specific commands, is greyed out and inaccessible. In 2015 all of the above worked perfectly.

I am using fully updated OS X El Capitan with the latest 3DX driver from their site. I have tried re-installing this as well but to no avail. I am unable to find anything helpful on the 3DConnexion site forum. I have yet to contact their tech support. Thought I would try here first.

Anyone else experiencing the same thing?


#11

Make sure the 3dx plugin is enabled in Preferences/Extensions


#12

@david_macd, I had to open and close the ‘System Preferences’ for it, after upgrading to El Capitan…

it seemed to then become available, as if it had been ‘sandboxed’…

One way to tell is to open ‘Ruby Console’ in SU and then open a new model…

If you get an error message

Error: #<RangeError: integer 140269540388080 too big to convert to `int'>
SketchUp:1:in `onNewModel'

then it’s Installed properly…
john


#13

It wasn’t. Thanks for that one. I have enabled it and closed and re-opened Sketchup. But, sadly no change. Tried re-installing 3DX driver again. No change.

Tried john-drivenupthewall’s test and I get the error message which he says indicates it’s working.

And yes it is working … but it’s un-programmable in the 3DConnexion Preference Pane when Sketchup is selected in the drop down program list. The panel accepts my changes but does not implement them. I cannot do even basics like switching on and off “Dominant” or changing speed. The Sketchup Application Commands are also still greyed and unavailable.

On the face of it looks like a 3DX issue but it programs perfectly in Any Application, Google Earth and Photoshop. The refusal to be programmed is definitely Sketchup specific.

Curious …


#14

John

Tried your test and I get the error message. For rest of the story see my reply to Box above.

David Mac


#15

Sorry to hear that, but as a non mac person I have reached the end of my available suggestions.


#16

Thanks Box.

The odd thing is it worked perfectly in exactly the same system configuration with 2015.

Ho hum …


#17

Are you holding your mouth right!


#18

Honestly, I see the error as a bug in the plugin for SU, and have reported it as such to both 3dConnexion and Trimble…

Send them a ‘ticket’ with the message pasted in and they may escalate the issue and fix the driver…

john


#19

I had an issue the first time that I loaded 2016. This was my final solution:

  1. Download the newest driver from 3Dconnexion
  2. Uninstall old driver (including preference files)
  3. Restart
  4. Install new driver

Then it worked… I will point out, though, it will only work on ONE version of SketchUp at a time. by that I mean if you open 2015, then use your 3D mouse, then open 2016 and try to use your mouse, odds are good that it wont work in either 2015 or 2016.

Hopefully that helps! If not, keep on 3Dconnexion. They have a very good help department!


#20

Aaron, do you see the error with your install?

I also have the latest driver, ‘fresh’ installed after the release of v16…

john