How to initialize a 3D mouse?

My 3D SpacePilot Pro mouse works with Sketchup 2019, I am trying out Sketchup 2023.
The 3D mouse does not work, it seems like it is not connected/initialized.
Windows 10 user.
Thanks for the replies.

Download and install the latest drivers from 3DConnexion.

Thanks David for the quick reply. I did that. I have the newest version.
Is there somethihng moe I need to do.

I see there is a folder under the 3Dconnexion folder:
C:\Program Files\3Dconnexion\3DxWare\3DxSketchUp

Should Sketchup some how point to that folder?


Did you restart SketchUp after you installed the latest drivers?

Yes, I even rebooted.

Did you install SketchUp correctly? That requires right clicking on the installer and selecting Run as administrator.

No, I will uninstall it and try again.

Thanks for the reply.


I uninstalled and reinstalled as Administrator. Same result.
Why ties the 3D mouse to SketchUp?
There seems to be a missing step.


I use 3D mouse with sketchup 2023 and there’s no issue, just launch the 3D conexion software go to add device and follow the instructions, if it doesn’t work unplug and plug again the receiver.

Thanks, now slow down where do you access the 3D conexion sofware?

Go to Extensions/Extension Manager and check to see if the 3DxSketchUp file is there and enabled.

Having reinstalled Sketchup you should reinstall the 3d connexion Driver also as it needs the software available for it to recognise it and install the extension files. For example if you have 2022 installed and you install the 3d connexion software, then install 2023 the driver will work for 2022 but not 2023 as it wasn’t there for it to create the files for.

You say it is a 3D SpacePilot Pro, is that quite an old model? If so it may not work with the newer drivers.
What you may need to do is track down the .rb and folder that is working for 2019 and manually copy them to the Plugins folder of 2023.

Edit: From memory the file location that the 3d connexion creates is
C:\ProgramData\SketchUp\SketchUp 2019\SketchUp\Plugins
If you can find that folder on your system copy the file and folder both called 3DxSketchUp and paste them into
C:\Users\YOUR USER NAME\AppData\Roaming\SketchUp\SketchUp 2023\SketchUp\Plugins
being sure to use your user name. This folder may be hidden, you would need to tell Windows Explorer to show hidden if you haven’t already.
Also the Plugins folder may not yet exist in the 2023 file structure if you haven’t installed any other Extensions.

I’m on a Mac not Windows, but last week I had a failure to install the 3D Connection extension on the first try because the installer didn’t automatically check mark the versions of SketchUp to install it into. I had to click in on myself manually. Also, it called them “SketchUp Player” which was confusing language. Just a thought.

I installed SU 2023 over the weekend and my SpaceMouse failed. After reinstalling 3DxWare, it worked again. 3DxWare 10 Archives - 3Dconnexion US

No need to launch 3DxWare but you can confirm the SpaceMouse is working with the 3Dconnexion Home app.

You download it from the 3D conexion website.

I do not have 3DxSketchup in the Sketchup Extension Manager.
How would I install it?

Thanks for all of the replies.


The 3DxSketchUp.rb is in the C/ProgramFiles/3Dconnexion/3DxWare/3DxSketchUp folder. From the Extension Manager, select “Install Extension”. Point to the file/location indicated above.

Yoy mentioned that you uninstalled and reinstalled SketchUp. You may have to uninstall then reinstall 3Dconnexion’s software after.

I recommend uninstalling 3DCX software, rebooting, then downloading and installing it.

Extension Manager does not like .rb files.

It is looking for .rbz files. I tried changing the extension to .rbz but it did not like it.


Changing the extension from .rb to .rbz does not make it a .rbz file that SketchUp would install. You would need to put the .rb file into a ZIP file and then rename it from .zip to .rbz. Then you can use Install Extension to install it. Or just open the Plugins folder and paste the .rb file into it.

Does your 3DConnection Home app work?

Opps on the .rb.

I don’t think that I’ve had to install the Extension from Extension Manager. Just 3DxWare.