"You Have Exceeded Your Allowed Activations" SketchUp 2022

I’m trying to install the SketchUp 2022 release, and I’m getting the message “You Have Exceeded Your Allowed Activations” when I try to log in.

I’ve gone through the “Manage Activations” step, then used the Trimble “My Products” page to deauthorize all devices for SketchUp Pro.

image

I click on the deauthorize all button, it tells me my changes are completed, but I’m getting the same message on my computer when I try to authorize SketchUp 2022.

I’ve also tried to go back and manually log out of my SketchUp installs on my laptop, my old laptop, etc, but it still gives me the message about too many activations.

What am I missing here?

2 Likes

Hello Justin
You have to disconnect from Su 2021 before
And close su 2021 and 2022 sessions
Restart SU2022, login, it could be ok !?
If not , disconnect from Trimble account, restart su 2022, login .
I had to do that!

There’s no auto translation in my phone! perhaps my English wasn’t perfect!
:smiling_face:

I had the same problem, then realized that the window telling you about the activation issue is actually overlaid EXACTLY (the same size) as the “welcome to sketchup window” beneath it, once you’ve gone through the flush-other-logins procedure. The trouble is when its successful, it doesn’t close the warning window to reveal the “welcome” window below!

mmm, you might have accidentally started SketchUp twice because there is only one Welcome screen with just different loading content.

Hmmm - I’ll have to try this when I get home and see if it helps - I’ll confess I didn’t try this particular solution :slight_smile:

Thanks!

1 Like

This one I did try - I logged out from 2021 before I logged into 2022 and it didn’t work.

Thanks though!

Justin: did you also log out of SketchUp 2022 and then sign back in? You can use the profile icon at the top of that dialog to do this.

I think I got it working - I’m not sure which of these in the thread really fixed it, but I went back and re-logged in and logged out of both 2021 and 2022, then logged back in to 2022 and it looks like it fired up ok.

My internet connection at my house isn’t very good and it’s caused some weird issues like this in the past - I did all this at the office with a better connection and that’s when it worked, so it could have been a poor connectivity issue too.

No idea what wasn’t working before, but thanks everyone for your help! :smile:

1 Like

I was having this same issue with installing SketchUp Pro 2022, but after reading this forum, I got it working. What a mess. I am sill having an issue with removing SketchUp Pro 2021. Maybe I can uninstall it now. Is there any issues I need to be concerned about before uninstalling SketchUp Pro 2021?

1 Like

They can co-exist. Many have multiple versions on their machines. If you ned to remove 2021 due to lack of disk space, feel free to.

Generally I recommend keeping the previous version of SketchUp loaded on your computer for a while just in case some of your extensions haven’t been updated for the new version yet. Otherwise you won’t be able to use them until they get updated

Ok sketchup. what exactly are the instructions here. i am trying to make this work but going around in circles. same problem as Justin originally posted

Finally got it to work, but had to try all sorts of things, such as de authorise all applications, log in, log out, shutdown restart. Not sure what worked but it did take at least 5 attempts

Had the same problem, found the answer here:
Managing Subscription Plans | SketchUp Help
The answer can be found about halfway down.
Don’t forget to sign out on the top right hand corner of the dialog box that comes up when you try to start Sketchup 2022.

Lol - this was exactly my experience - I have no idea what finally worked, but it worked! :sunglasses:

My experience also.

Here’s the answer to 2022 too many machines issue if deauthorize doesn’t work:

  1. Log out from SU 2022
  2. go to %AppData%\SketchUp\SketchUp 2022\SketchUp\
  3. delete login_session.dat
  4. Login once again

Hi Everyone

Activations are tracked across versions of SketchUp. So the best thing to do if you are seeing that message after installing the new version is first sign out of 2022 then close it down. Then open your previous versions and sign out of those. Each explicit sign out should remove and activation from they system. Once you’re done clearing older versions, open 2022 and sign in.

We realize this system isn’t very user friendly after a few major upgrades so we do plan to improve this in the future.

Bryce

3 Likes

Hey - not on topic, but I just wanted to thank you directly for your SU videos - they’re the best. -Tim McKenna, AIA

1 Like

Glad I’ve been able to help! :smile: